Bug 1264745 - perl-Lingua-EN-Fathom-1.15-6.fc24 FTBFS: t/main.t tests fail
perl-Lingua-EN-Fathom-1.15-6.fc24 FTBFS: t/main.t tests fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Lingua-EN-Fathom (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 02:41 EDT by Petr Pisar
Modified: 2015-10-01 07:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Lingua-EN-Fathom-1.18-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-01 07:58:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-09-21 02:41:32 EDT
perl-Lingua-EN-Fathom-1.15-6.fc24 fails to build in F24:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
#   Failed test 'sub syllables_per_word'
#   at t/main.t line 40.
#                   '1.39473684210526'
#     doesn't match '(?^:^1.4473684210526)'
#   Failed test 'sub flesch'
#   at t/main.t line 43.
#                   '75.9835964912281'
#     doesn't match '(?^:^71.5309649122807)'
#   Failed test 'sub kincaid'
#   at t/main.t line 44.
#                   '5.8078947368421'
#     doesn't match '(?^:^6.42894736842105)'
# Looks like you failed 3 tests of 13.
t/main.t .......... 
Dubious, test returned 3 (wstat 768, 0x300)
Failed 3/13 subtests

Difference between working and failing build root:

        perl-Lingua-EN-Syllable 	0.251-6.fc23 	> 	1:0.28-1.fc24
	glibc 	2.22.90-3.fc24 	> 	2.22.90-6.fc24
	glibc-devel 	2.22.90-3.fc24 	> 	2.22.90-6.fc24
	glibc-common 	2.22.90-3.fc24 	> 	2.22.90-6.fc24
	kernel-headers 	4.3.0-0.rc1.git2.1.... 	> 	4.3.0-0.rc1.git3.1....
	glibc-headers 	2.22.90-3.fc24 	> 	2.22.90-6.fc24
	systemd-libs 	226-1.fc24 	> 	226-2.fc24
	systemd 	226-1.fc24 	> 	226-2.fc24

Note You need to log in before you can comment on or make changes to this bug.