Bug 126475 - XVideo extension fails when Nautilus uses a wallpaper
XVideo extension fails when Nautilus uses a wallpaper
Status: CLOSED DUPLICATE of bug 123996
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-22 04:41 EDT by Motor
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf configuration file (3.71 KB, text/plain)
2004-06-22 04:42 EDT, Motor
no flags Details

  None (edit)
Description Motor 2004-06-22 04:41:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.15

Description of problem:
Playback of DVDs and other high resolution video via the XVideo
extension fails when the GNOME Nautilus file manager has a desktop
background set, or XMMS is loaded. Failure occurs with mplayer, ogle
and xine.


Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. Right click Nautilus desktop background and select "Change Desktop
background"
2. Change to "Vertical Gradient"
3. run media player

Actual Results:  
>ogle

X Error of failed request:  BadAlloc (insufficient resources for
operation)
  Major opcode of failed request:  143 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  82
  Current serial number in output stream:  82

mplayer:
>mplayer dvd://2

VDec: vo config request - 720 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 768x576 Planar YV12

X11 error: BadAlloc (insufficient resources for operation)  0.0% 0 0 0%

xine:
Doesn't display an error, just refuses to show any video -- it
displays a blue screen with audio.

Expected Results:  Video output via XVideo

Additional info:

System specs:
Matrox G550 (32mb video ram)
AMD Athlon XP2000+
512MB RAM

System upgraded from FC1 to FC2. xorg.conf generated by
system-display-config. I'm entering this bug in x11-org because it did
not occur in the previous XFree86 in FC1, and it's hard to believe
that either a Nautilus vertical gradient background or XMMS is
exhausting 32Mb of Video RAM. Lower resolution video clips will still
play via XVideo with a Nautilus background or XMMS running.

>xvinfo

X-Video Extension version 2.2
screen #0
  Adaptor #0: "Matrox G-Series Backend Scaler"
    number of ports: 1
    port base: 69
    operations supported: PutImage
    supported visuals:
      depth 16, visualID 0x23
      depth 16, visualID 0x24
      depth 16, visualID 0x25
      depth 16, visualID 0x26
      depth 16, visualID 0x27
      depth 16, visualID 0x28
      depth 16, visualID 0x29
      depth 16, visualID 0x2a
      depth 16, visualID 0x2b
      depth 16, visualID 0x2c
      depth 16, visualID 0x2d
      depth 16, visualID 0x2e
      depth 16, visualID 0x2f
      depth 16, visualID 0x30
      depth 16, visualID 0x31
      depth 16, visualID 0x32
    number of attributes: 4
      "XV_COLORKEY" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 2110)
      "XV_BRIGHTNESS" (range -128 to 127)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_CONTRAST" (range 0 to 255)
              client settable attribute
              client gettable attribute (current value is 128)
      "XV_DOUBLE_BUFFER" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
    maximum XvImage size: 1024 x 1024
    Number of image formats: 4
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
Comment 1 Motor 2004-06-22 04:42:31 EDT
Created attachment 101322 [details]
xorg.conf configuration file
Comment 2 Joe Ceklosky 2004-06-24 21:01:00 EDT
I have a Matrix G550 card showing the exact same problems.  The card
worked fine with Xfree 4.3.0, Fedora Core 1, and linux 2.4.X
Comment 3 Motor 2004-06-25 18:42:22 EDT

*** This bug has been marked as a duplicate of 123996 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:04:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.