Bug 1264751 - perl-Net-DNS-1.01-2.fc24 FTBFS in mock: sign_sig0: unexpected Net::DNS::RR argument at t/04-packet.t line 198.
perl-Net-DNS-1.01-2.fc24 FTBFS in mock: sign_sig0: unexpected Net::DNS::RR ar...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Net-DNS (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://ppisar.fedorapeople.org/perl_...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 03:00 EDT by Petr Pisar
Modified: 2015-09-21 07:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-Net-DNS-1.01-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 07:56:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-09-21 03:00:04 EDT
perl-Net-DNS-1.01-3.fc24 fails to build in F24 mock environment for me when bootstrapping perl packages with this test failure:

t/03-rr.t ..................... ok
sign_sig0: unexpected Net::DNS::RR argument at t/04-packet.t line 198.
SIG0: unable to sign packet at t/04-packet.t line 198.
# Looks like you planned 101 tests but ran 96.
# Looks like your test exited with 2 just after 96.
t/04-packet.t ................. 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 5/101 subtests 
t/05-A.t ...................... ok

It passes in koji (that has no Internet access), but I suspect there is some bug. I cannot reproduce it elsewhere.
Comment 1 Petr Pisar 2015-09-21 05:15:23 EDT
I'm able to reproduce it when using packages from the bootstrap. Difference between working and failing build root is:

Removed packages:
        perl-Crypt-OpenSSL-Bignum-0.06
        perl-Crypt-OpenSSL-DSA-0.15
        perl-Crypt-OpenSSL-EC-1.01
        perl-Crypt-OpenSSL-ECDSA-0.07
        perl-Crypt-OpenSSL-Random-0.10
        perl-Crypt-OpenSSL-RSA-0.28
        perl-HTTP-Tiny-0.056
        perl-MIME-Base32-1.02a
        perl-Net-DNS-1.01
        perl-Net-DNS-SEC-1.01
        perl-Time-Local-1.2300
Added packages:
        elfutils-default-yama-scope-0.163

I'm pretty sure I tested the bootstrapping properly when I introduced it. I will recheck it.
Comment 2 Petr Pisar 2015-09-21 07:36:51 EDT
The difference in build root is caused by wrong dependency list on perl.spec's perl-Pod-Perldoc subpackage. I will correct it in perl.spec.

Yet I need to figure out why the test fails without perl-HTTP-Tiny and perl-Time-Local.
Comment 3 Petr Pisar 2015-09-21 07:49:26 EDT
It fails because the t/04-packet.t exhibits lib/Net/DNS/RR/SIG.pm that uses Time::Local. The real failure cause is hidden by eval used to load the Net::DNS::RR::SIG.

I will add the Time::Local to build-time dependencies.

Note You need to log in before you can comment on or make changes to this bug.