Bug 1264772 - gdeploy: gdeploy expects brick_dirs even when force is enabled over existing brick mounts [NEEDINFO]
gdeploy: gdeploy expects brick_dirs even when force is enabled over existing ...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sachidananda Urs
Anush Shetty
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 03:48 EDT by Anush Shetty
Modified: 2015-11-24 02:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 02:09:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
surs: needinfo? (ashetty)


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2015-09-21 03:48:21 EDT
Description of problem: While creating a volume with existing brick mounts, gdeploy expects brick_dirs to be set even when force option is enforced.


Version-Release number of selected component (if applicable): 
gdeploy-1.0-12.el6rhs.noarch

How reproducible: Always


Steps to Reproduce:
1. Create a config file:

[hosts]
rhshdp03.lab.eng.blr.redhat.com
rhshdp04.lab.eng.blr.redhat.com
rhshdp05.lab.eng.blr.redhat.com
rhshdp06.lab.eng.blr.redhat.com

[mountpoints]
/gluster1/brick1/


[tune-profile]
none

[peer]
manage=probe

[volume]
action=create
volname=gluster_vol1
replica=yes
replica_count=2
force=yes


2. Run gdeploy: gdeploy -c gluster.conf

Actual results: 

Error: Section 'brick_dirs' or 'mountpoints' not found.
Cannot continue volume creation!


Expected results: Should accept mountpoints values as brick dir when force option is enabled.


Additional info:
Comment 2 Nandaja Varma 2015-09-21 04:15:45 EDT
This is not a bug. It is the expected behavior. If not doing back-end setup you are supposed to give the brick_dirs, not the mountpoint.
As the documentation of brick_dirs say:

IMP: If only volume creation is to be done and not back-end setup, just                                                               
give the relative path of bricks in this section for the hosts specified
in the [hosts] section along with the 'volume' section.
Comment 3 Sachidananda Urs 2015-11-06 11:38:56 EST
Anush see if you agree with Comment 2, if so I can mark this as not a bug.
Comment 4 Sachidananda Urs 2015-11-24 02:09:53 EST
Anush, marking this as not a bug. Re-open if you think otherwise.

Note You need to log in before you can comment on or make changes to this bug.