Bug 126480 - Dovecot without vpopmail authentication
Summary: Dovecot without vpopmail authentication
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dovecot   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-22 09:34 UTC by Yavor Christov
Modified: 2014-01-21 22:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 01:44:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yavor Christov 2004-06-22 09:34:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Dovecot comes without vpopmail authentication compiled in binary
provided by the rpm package.

When dovecot is compiled from source with default configure options
vpopmail authentication mechanism is included. What are the reasons
Fedora rpm to come without it? Can it be included in next update?

Version-Release number of selected component (if applicable):
dovecot-0.99.10.4-4 and the dovecot-0.99.10.5-0.FC1 update

How reproducible:
Always

Steps to Reproduce:
1. Install dovecot rpm
2. Edit /etc/dovecot.conf to use vpopmail authentication
3. Start dovecot (/etc/init.d/dovecot start)
    

Actual Results:  
snippet from maillog:

---
Jun 21 12:42:18 mail dovecot: Dovecot starting up
Jun 21 12:42:20 mail dovecot-auth: Unknown userdb type 'vpopmail'
Jun 21 12:42:20 mail dovecot: Auth process died too early - shutting down
Jun 21 12:42:20 mail dovecot: child 18802 (auth) returned error 89
Jun 21 12:42:20 mail imap-login: fd_send(-1) failed: Broken pipe
Jun 21 12:42:20 mail last message repeated 2 times
---

Additional info:

Comment 1 Warren Togami 2004-06-23 01:44:12 UTC
We cannot fix this without including vpopmail in the Fedora
distribution, which will not happen.  The best you can do is rebuild
the SRPM when vpopmail is installed on your system.

WONTFIX... unless Timo can do something upstream, but that is doubtful.


Note You need to log in before you can comment on or make changes to this bug.