Bug 1264839 - Dovecot must not generate its certificates and dhparam at installation
Dovecot must not generate its certificates and dhparam at installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 06:56 EDT by Juan Orti
Modified: 2015-12-08 13:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 13:08:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Orti 2015-09-21 06:56:08 EDT
Description of problem:
"dnf install dovecot" took almost an hour to finish because it was generating the dhparams at %post.

You must use a dovecot-init.service to generate the certificates, dh params, and other first-run setup.

https://fedoraproject.org/wiki/Packaging:Initial_Service_Setup

A similar case was discussed recently in the packaging mailing list:

https://lists.fedoraproject.org/pipermail/packaging/2015-September/011008.html


Version-Release number of selected component (if applicable):
dovecot-2.2.18-4.fc23.armv7hl
Comment 1 Michal Hlavinka 2015-12-08 13:08:31 EST
It will propagate to other active Fedora releases later together with next dovecot update.

Note You need to log in before you can comment on or make changes to this bug.