Bug 1264892 - npm unable to find modules in rhscl 2.1
npm unable to find modules in rhscl 2.1
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: npm (Show other bugs)
nodejs010
Unspecified Unspecified
high Severity high
: beta
: 2.1
Assigned To: Zuzana Svetlikova
Miroslav Hradílek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 08:22 EDT by Miroslav Hradílek
Modified: 2015-11-16 10:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 10:09:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Hradílek 2015-09-21 08:22:42 EDT
Description of problem:
After update to the currently unreleased packages npm does not work. Instead error is returned:

Error: Cannot find module './lib/_stream_duplex.js'
or
Error: Cannot find module './lib/cookies' 

Version-Release number of selected component (if applicable):
nodejs010-2.1-2.el7.x86_64
nodejs010-nodejs-0.10.40-1.el7.x86_64
nodejs010-npm-1.4.28-4.el7.noarch


Full tracebacks:

# scl enable nodejs010 'npm -h'

module.js:340
    throw err;
    ^
Error: Cannot find module './lib/_stream_duplex.js'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/opt/rh/nodejs010/root/usr/lib/node_modules/readable-stream/duplex.js:1:80)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)


OR

# scl enable nodejs010 npm

module.js:340
    throw err;
          ^
Error: Cannot find module './lib/cookies'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/opt/rh/nodejs010/root/usr/lib/node_modules/request/index.js:16:29)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
Comment 4 errata-xmlrpc 2015-11-16 10:09:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2032.html

Note You need to log in before you can comment on or make changes to this bug.