Bug 126491 - possible ecj miscompilation in ant
Summary: possible ecj miscompilation in ant
Status: CLOSED DUPLICATE of bug 130010
Alias: None
Product: Fedora
Classification: Fedora
Component: ecj   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-22 13:23 UTC by Gary Benson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gary Benson 2004-06-22 13:23:42 UTC
Description of problem:
If you build ant using ecj-ant then attempting to compile ant.jar to
native code spits out the following error:

org/apache/tools/ant/taskdefs/FixCRLF.java: In class
`org.apache.tools.ant.taskdefs.FixCRLF':
org/apache/tools/ant/taskdefs/FixCRLF.java: In method
`org.apache.tools.ant.taskdefs.FixCRLF.processFile(java.lang.String)':
org/apache/tools/ant/taskdefs/FixCRLF.java:395: error: verification
error at PC=630
org/apache/tools/ant/taskdefs/FixCRLF.java:395: error: might transfer
control into subroutine
+

Version-Release number of selected component (if applicable):
ecj-2.1.3-1 (in bootstrap-ant-1.5.2-1), ant-1.5.2-29

Additional info:
This is worked around in ant.spec by prebuilding the offending class
with gcj.

Comment 1 Gary Benson 2004-09-08 10:59:50 UTC

*** This bug has been marked as a duplicate of 130010 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:04:11 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.