Bug 126502 - [agpgart] VIA KT333 northbridge is not correctly recognized
[agpgart] VIA KT333 northbridge is not correctly recognized
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-22 11:35 EDT by Dawid Gajownik
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-06 05:43:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawid Gajownik 2004-06-22 11:35:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7) Gecko/20040616

Description of problem:
Hi!

I noticed today by accident that my northbridge is not correctly
recognized (it's good to have option quiet disabled). I looked through
the /var/log/messages* files and find out that the last good kernel
was 2.6.6-1.406. I had this message:

Jun  4 18:15:45 X kernel: Linux version 2.6.6-1.406
(bhcompile@tweety.build.redhat.com) (gcc version 3.3.3 20040412 (Red
Hat Linux 3.3.3-7)) #1 Tue Jun 1 13:45:43 EDT 2004
[snip]
Jun  4 18:15:45 X kernel: Real Time Clock Driver v1.12
Jun  4 18:15:45 X kernel: Linux agpgart interface v0.100 (c) Dave Jones
Jun  4 18:15:45 X kernel: agpgart: Detected VIA KT266/KY266x/KT333 chipset
Jun  4 18:15:45 X kernel: agpgart: Maximum main memory to use for agp
memory: 439M
Jun  4 18:15:45 X kernel: agpgart: AGP aperture is 64M @ 0xe0000000
Jun  4 18:15:45 X kernel: Serial: 8250/16550 driver $Revision: 1.90 $
8 ports, IRQ sharing enabled

My next kernel was 2.6.6-1.422 and since then this bug has appeared in
all versions (even in 2.6.7-1.441).

Jun  5 13:05:57 X kernel: Linux version 2.6.6-1.422
(bhcompile@porky.devel.redhat.com) (gcc version 3.3.3 20040412 (Red
Hat Linux 3.3.3-7)) #1 Fri Jun 4 13:00:45 EDT 2004
[snip]
Jun  5 13:05:57 X kernel: Linux agpgart interface v0.100 (c) Dave Jones
Jun  5 13:05:57 X kernel: agpgart: Detected VIA P4X266 chipset
Jun  5 13:05:57 X kernel: agpgart: Maximum main memory to use for agp
memory: 439M
Jun  5 13:05:57 X kernel: agpgart: AGP aperture is 64M @ 0xe0000000

I have Soltek SL-75DRV5 motherboard with VIA KT333 north bridge and
AMD Athlon XP CPU. I don't know is that related with that bug, but
Mozilla can even use 50% of my CPU on pages with floating text from
one side to another (I'm using nv driver).


Version-Release number of selected component (if applicable):
everything newer than kernel-2.6.6-1.406

How reproducible:
Always

Steps to Reproduce:
1. boot machine with broken kernel
2.
3.
    

Expected Results:  Chipset should be recognized correctly.

Additional info:
Comment 1 Dawid Gajownik 2004-07-06 05:43:06 EDT
I don't know whether this bug had been noticed, but it seems to be
fixed in kernel 2.6.7-1.471. Thanks!

Note You need to log in before you can comment on or make changes to this bug.