Bug 1265039 - configuring openscap on clients registered pre 6.1.1, receive error "Please check that Content host is linked to Foreman host"
configuring openscap on clients registered pre 6.1.1, receive error "Please c...
Status: CLOSED DUPLICATE of bug 1259188
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
6.1.2
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-21 20:34 EDT by Kathryn Dixon
Modified: 2015-10-21 11:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 11:25:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kathryn Dixon 2015-09-21 20:34:40 EDT
Description of problem:

Clients registered to satellite (6.0.4/8) before implementing openscap with 6.1.1, must be unregistered then reregistered to allow the uuids to "match up"

"the clients get all the info needed from the pupped module, the client successfully uploads the result to foreman-proxy, but when foreman-proxy send it to foreman, it returns a 500 internal server error."

the foreman log has these entries when it uploads:

2015-09-10 08:47:17 [I] Processing by Api::V2::Compliance::ArfReportsController#create as */*
2015-09-10 08:47:17 [I]   Parameters: {"apiv"=>"v2", "cname"=>"93ce6b02-dc2a-4ac6-8fb5-57b9d8f54150", "policy_id"=>"1", "date"=>"2015-09-08"}
2015-09-10 08:47:17 [E] Could not find Host with name: 93ce6b02-dc2a-4ac6-8fb5-57b9d8f54150
2015-09-10 08:47:17 [E] Please check that Content host is linked to Foreman host
2015-09-10 08:47:17 [I] ActiveRecord::RecordNotFound (ActiveRecord::RecordNotFound)
2015-09-10 08:47:17 [I]   Rendered api/v2/errors/not_found.json.rabl within api/v2/layouts/error_layout (1.7ms)

The result sits in the spool directory.

------

2015-09-21 10:29:32 [I] Processing by Api::V2::Compliance::ArfReportsController#create as */*
2015-09-21 10:29:32 [I]   Parameters: {"apiv"=>"v2", "cname"=>"93ce6b02-dc2a-4ac6-8fb5-57b9d8f54150", "policy_id"=>"3", "date"=>"2015-09-21"}
2015-09-21 10:29:32 [E] Could not find Host with name: 93ce6b02-dc2a-4ac6-8fb5-57b9d8f54150
2015-09-21 10:29:32 [E] Please check that Content host is linked to Foreman host
2015-09-21 10:29:32 [I] ActiveRecord::RecordNotFound (ActiveRecord::RecordNotFound)
2015-09-21 10:29:32 [I]   Rendered api/v2/errors/not_found.json.rabl within api/v2/layouts/error_layout (1.7ms)
2015-09-21 10:29:32 [I] Completed 404 Not Found in 59ms (Views: 25.3ms | ActiveRecord: 3.5ms)
2015-09-21 10:29:33 [W] Creating scope :latest. Overwriting existing method Scaptimony::ArfReport.latest.
Version-Release number of selected component (if applicable):


How reproducible:



Steps to Reproduce:
1. register client with satellite 6.0.8
2. upgrade satellite to 6.1.2, ensure sat-tools repo gets on client
3. start openscap process
4. clients will fail with uuid don't match/ or can't be found.

Actual results:

2015-09-11 10:41:49 [I]   Parameters: {"apiv"=>"v2", "cname"=>"93ce6b02-dc2a-4ac6-8fb5-57b9d8f54150", "policy_id"=>"3", "date"=>"2015-09-11"}
2015-09-11 10:41:49 [E] Could not find Host with name: 93ce6b02-dc2a-4ac6-8fb5-57b9d8f54150
2015-09-11 10:41:49 [E] Please check that Content host is linked to Foreman host


Expected results:

The uuids should match, regardless if they were registered before openscap.


Additional info:
workaround-
unregistering and re registering does solve this, but if your environment has many vms this can cause a headache.
Comment 1 Brad Buckingham 2015-10-21 11:25:19 EDT
This bug appears to be a duplicate of bug 1259188.  That bug is targeted for resolution in 6.1.4.  If the issue persists after upgrading to a version of Satellite 6.1.x that contains that fix, please feel free to re-open.

*** This bug has been marked as a duplicate of bug 1259188 ***

Note You need to log in before you can comment on or make changes to this bug.