Bug 126504 - vnc install fails to start
vnc install fails to start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-22 12:09 EDT by Jesse Barnes
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 13:09:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Barnes 2004-06-22 12:09:19 EDT
Passing 'vnc' on the boot line causes a failure right around the 
time that the vnc server should start, looks like something in the X 
server config is broken? 
 
 
Probing for mouse type:   No - mouse 
No video hardware found, assuming headless 
Starting VNC... 
 
 
WARNING!!! VNC server running with NO PASSWORD! 
You can use the vncpassword=<password> boot option 
if you would like to secure the server. 
 
 
The VNC server is now running. 
Please connect to altix2.lab.boston.redhat.com:1 to begin the 
install... 
X SERVER STARTED, THEN FAILEDTraceback (most recent call last): 
  File "/usr/bin/anaconda", line 941, in ? 
    vncconnectport=vncconnectport) 
  File "/usr/bin/anaconda", line 217, in startVNCServer 
    doStartupX11Actions() 
  File "/usr/bin/anaconda", line 257, in doStartupX11Actions 
    raise RuntimeError, "X server failed to start" 
RuntimeError: X server failed to start 
install exited abnormally 
sending termination signals...done 
sending kill signals...done 
disabling swap... 
unmounting filesystems... 
        /mnt/runtime done 
        disabling /dev/loop0 
        /proc done 
        /dev/pts done 
        /sys done 
        /tmp/ramfs done 
        /mnt/source done 
you may safely reboot your system
Comment 1 Jeremy Katz 2004-06-22 12:13:05 EDT
Or vnc broke on ia64 again...  will look at after lunch.
Comment 2 Jeremy Katz 2004-06-22 14:03:46 EDT
Actually, this was just a general problem caused by an explicit
listing of libstdc++.so.5 in upd-instroot.  Made more general so that
it will get the (new) libstdc++.so.6 instead.
Comment 3 Jesse Barnes 2004-08-19 13:08:53 EDT
This works now, I tried it yesterday on the 0816 RHEL4 build. 

Note You need to log in before you can comment on or make changes to this bug.