Bug 1265051 - Finish up FlagType webservice API
Finish up FlagType webservice API
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
4.4
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
Rony Gong
:
Depends On: 1212264 1537385
Blocks: 1266816
  Show dependency treegraph
 
Reported: 2015-09-21 22:36 EDT by Matt Tyson
Modified: 2018-03-11 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-11 19:00:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 1210292 None None None Never

  None (edit)
Description Matt Tyson 2015-09-21 22:36:23 EDT
We have customizations for creating a FlagType via RPC, but none for modifying or querying FlagTypes.

It would simplify some management tasks if we added RPC methods to modify and query FlagTypes.
Comment 2 Matt Tyson 2015-09-29 01:29:14 EDT
This is tripping up on the same problem in bug 1212264.

Hash keys can't contain spaces and other words bugzilla thinks are evil.
I'll need to discuss this with upstream, or find another way to design the API.
Comment 3 Matt Tyson 2015-10-01 01:15:49 EDT
As it turns out, 5.0 has a FlagTypes API, which also exhibits the dropping-bad-hash-names problem.

I've filed a bug upstream.  Hopefully they will be able to suggest a way to resolve this.
Comment 4 Jeff Fearn 2018-03-11 19:00:57 EDT
BZ 5 has an upstream version of this that should work for us.

Note You need to log in before you can comment on or make changes to this bug.