Bug 1265159 - Error initializing GPT disk under Windows Server 2012R2 - does not affect viostor 104
Error initializing GPT disk under Windows Server 2012R2 - does not affect vio...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.0
x86_64 Windows
unspecified Severity high
: pre-dev-freeze
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks: 1288337
  Show dependency treegraph
 
Reported: 2015-09-22 05:10 EDT by Alex Leake
Modified: 2016-07-04 01:32 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-04 01:32:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Leake 2015-09-22 05:10:59 EDT
Description of problem:

Error relating to initialization of GPT disks under Windows 2012R2, duplicate of 1212392 - impacting newer viostor drivers.


Version-Release number of selected component (if applicable):

viostor builds: 103, 104, 109


How reproducible:

Always. 104 works, 103 / 109 do not.


Steps to Reproduce:
1. Install either viostor build 103 or 109 (Windows drivers) using a virtio-blk disk
2. Attempt to initialize disk as GPT

Actual results:

"Incorrect function".

Expected results:

Disk initialization. 

Additional info:

I know this is a duplicate, but the bug must of been re-introduced somewhere.

viostor 109 does not work, nor does 103 - but 104 works perfectly...
Comment 1 John Matthews 2015-09-24 16:52:51 EDT
Please refile against the correct product, I'm unsure what product this is intended for, but it is not correct for Red Hat Cloud Suite.
Comment 2 Alex Leake 2015-09-25 03:21:54 EDT
John,

Sorry, in retrospect this is not a suitable category. It might affect the redhat cloud suite though, as this relates to the VirtIO windows drivers - so anything that can virtualise windows under KVM?

Which is the best category for VirtIO bugs?


Kind Regards,
Alex.
Comment 3 John Matthews 2015-10-13 14:43:32 EDT
Alex,

I'm re-assinging this to virtio-win.

Unsure if this is the correct component.  Best guess I had.
Comment 5 lijin 2015-10-19 02:53:57 EDT
I can NOT reproduce this issue with virtio-win-prewhql-109(https://brewweb.devel.redhat.com/buildinfo?buildID=451410).

steps:
1.# qemu-img create -f raw test.raw 5G
2.boot win2012R2 guest with one virtio-blk-pci device:
/usr/libexec/qemu-kvm -enable-kvm -m 4G -smp 4 -nodefconfig -nodefaults -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=win2012R2.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_r2_x64_dvd_2707946.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:11:1d:00:00,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:5 -vga cirrus -monitor stdio -drive file=test.raw,if=none,cache=none,format=raw,id=drive11 -device virtio-blk-pci,drive=drive11,id=disk11
3.install with virtio-win-prewhql-109 viostor driver in device manager
4.open disk management,initialize data disk as GPT
5.create new volume on the disk

Actual result:
disk can be initialized correctly and can create volume successfully.

Alex,could you check if is there anything I missed in my step?
I can reproduce with virtio-win-prewhql-103
Comment 6 Vadim Rozenfeld 2015-10-19 05:47:45 EDT
(In reply to lijin from comment #5)
> I can NOT reproduce this issue with
> virtio-win-prewhql-109(https://brewweb.devel.redhat.com/
> buildinfo?buildID=451410).

Can we recheck builds 105 and 106 (106 is almost equal to 109 in terms of viostor. build 110 is out of scope since for viostor driver it is equal to 105).

Thanks,
Vadim.
Comment 7 lijin 2015-10-19 06:38:04 EDT
(In reply to Vadim Rozenfeld from comment #6)
> (In reply to lijin from comment #5)
> > I can NOT reproduce this issue with
> > virtio-win-prewhql-109(https://brewweb.devel.redhat.com/
> > buildinfo?buildID=451410).
> 
> Can we recheck builds 105 and 106 (106 is almost equal to 109 in terms of
> viostor. build 110 is out of scope since for viostor driver it is equal to
> 105).

both build 105 and 106 work fine,blk disk can be initialized as GPT correctly.

> Thanks,
> Vadim.
Comment 8 Alex Leake 2015-10-19 07:10:49 EDT
All,

Interesting. Could this relate to the version of QEMU in use? To further complicate issues, these are RBD objects with Ceph.

In my setup I'm using:

- QEMU 2.2.0
- 3.16 Kernel
- Ceph Hammer (0.94 - for RBD device)

I'll try to recreate with local QEMU images to see if RBD is complicating matters.


Kind Regards,
Alex.
Comment 9 Vadim Rozenfeld 2015-10-19 20:31:11 EDT
(In reply to Alex Leake from comment #8)
> All,
> 
> Interesting. Could this relate to the version of QEMU in use? 

Probably not. There was a regression introduced in build 101
( bugfix for bug 1067225 - Windows guest performing out-of-bounds accesses on virtio device ). Then the problem was reported internally bz#1195487 and upstream, where it stop working for both GPT and MBR volumes on UEFI, then I hope it was finally fixed in build 106 (passed all WHQL testing Bug 1228967 - [virtio-win][whql][viostor]job "Flush Test" failed on all guests with build 105)


Cheers,
Vadim.

To further
> complicate issues, these are RBD objects with Ceph.
> 
> In my setup I'm using:
> 
> - QEMU 2.2.0
> - 3.16 Kernel
> - Ceph Hammer (0.94 - for RBD device)
> 
> I'll try to recreate with local QEMU images to see if RBD is complicating
> matters.
> 
> 
> Kind Regards,
> Alex.

Note You need to log in before you can comment on or make changes to this bug.