Bug 1265336 - dnf list and clean commands (and maybe others are broken)
dnf list and clean commands (and maybe others are broken)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 1265826 1266228 1266773 1266941 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 13:00 EDT by darrell pfeifer
Modified: 2015-10-13 15:30 EDT (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 04:57:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description darrell pfeifer 2015-09-22 13:00:14 EDT
Description of problem:

dnf stopped working

[root@localhost darrell]# dnf clean all
[root@localhost darrell]# dnf list updates
Last metadata expiration check performed 1:48:15 ago on Tue Sep 22 08:01:27 2015.
[root@localhost darrell]# dnf list dnf
Last metadata expiration check performed 1:55:57 ago on Tue Sep 22 08:01:27 2015.
[root@localhost darrell]# rpm -q dnf
dnf-1.1.2-2.fc24.noarch



Version-Release number of selected component (if applicable):




How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Kevin Fenzi 2015-09-23 13:22:28 EDT
I can confirm this here as well. 

downgrading to 1.1.1-2 and everything works again. 
Its just 1.1.2-2 that introduced the broken behavior.
Comment 2 Orion Poplawski 2015-09-23 13:24:57 EDT
Same here.  repolist is broken too.
Comment 3 Joachim Backes 2015-09-24 06:11:20 EDT
Same here! "dnf upgrade" does not run. But "dnf install <package>" works!
Comment 4 Michal Luscon 2015-09-24 06:11:30 EDT
Fixed in rawhide
Comment 5 Michal Luscon 2015-09-24 06:34:25 EDT
dnf-1.1.2-3.fc24 contains a revert of commit that introduced the regression - http://koji.fedoraproject.org/koji/buildinfo?buildID=687660
Comment 6 Peter Robinson 2015-09-24 06:47:15 EDT
(In reply to Michal Luscon from comment #5)
> dnf-1.1.2-3.fc24 contains a revert of commit that introduced the regression

I hope there's been a code test added so we can't regress again, issues like this should really be picked up by a test harness
Comment 7 Orion Poplawski 2015-09-24 11:15:55 EDT
dnf-1.1.2-3 does seem to work.
Comment 8 Filipe Rosset 2015-09-24 20:05:48 EDT
fixed here, thanks.
Comment 9 Michael Mráka 2015-09-25 05:36:45 EDT
*** Bug 1266228 has been marked as a duplicate of this bug. ***
Comment 10 Michael Mráka 2015-09-25 05:44:24 EDT
*** Bug 1265826 has been marked as a duplicate of this bug. ***
Comment 11 Michael Mráka 2015-09-29 04:12:23 EDT
*** Bug 1266941 has been marked as a duplicate of this bug. ***
Comment 12 Michael Mráka 2015-09-29 04:13:00 EDT
*** Bug 1266773 has been marked as a duplicate of this bug. ***
Comment 13 Christopher Meng 2015-09-29 21:14:09 EDT
Just a heads up for people don't know how to fix:


dnf reinstall dnf --allowerasing --best
Comment 14 RudraB 2015-09-30 02:04:52 EDT
fixed

Note You need to log in before you can comment on or make changes to this bug.