Bug 1265365 - Neutron missing pecan dependency
Neutron missing pecan dependency
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: python-pecan (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Liberty
Assigned To: Alan Pevec
yeylon@redhat.com
:
: 1265396 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 14:56 EDT by David Moreau Simard
Modified: 2016-04-18 03:13 EDT (History)
8 users (show)

See Also:
Fixed In Version: python2-pecan-1.0.2-2.el7 openstack-neutron-7.0.0-0.4.0rc1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:08:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Moreau Simard 2015-09-22 14:56:00 EDT
Neutron is currently missing the python-pecan dependency:
https://github.com/openstack/neutron/blob/957ac2b83e5beeff0b77e955a3a3475af016d27c/requirements.txt#L12

This is not a new dependency from today so my theory is that another project used and dropped pecan which neutron was feeding on.

pecan is not listed as a dependency for the package right now:
https://github.com/openstack-packages/neutron/blob/e1338eeab15fc5ab14a9f21a8be90d19845dd6ed/openstack-neutron.spec

This is causing neutron-server to fail to start:
 neutron-server[29019]: File "/usr/lib/python2.7/site-packages/neutron/cmd/eventlet/server/__init__.py", line 15, in <module>
 neutron-server[29019]: from neutron.server import wsgi_pecan
 neutron-server[29019]: File "/usr/lib/python2.7/site-packages/neutron/server/wsgi_pecan.py", line 22, in <module>
 neutron-server[29019]: from neutron.pecan_wsgi import app as pecan_app
 neutron-server[29019]: File "/usr/lib/python2.7/site-packages/neutron/pecan_wsgi/app.py", line 19, in <module>
 neutron-server[29019]: import pecan
 neutron-server[29019]: ImportError: No module named pecan
 systemd[1]: neutron-server.service: main process exited, code=exited, status=1/FAILURE
 systemd[1]: Failed to start OpenStack Neutron Server.

python-pecan currently in repo is outdated:
# yum info python-pecan
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: mirror.cogentco.com
Available Packages
Name        : python-pecan
Arch        : noarch
Version     : 0.8.3
Release     : 1.el7
Size        : 281 k
Repo        : delorean-common-testing/x86_64
Summary     : A lean WSGI object-dispatching web framework
URL         : http://github.com/dreamhost/pecan
License     : BSD
Description : A WSGI object-dispatching web framework, designed to be lean and
            : fast with few dependencies

We need to:
1) Bump python-pecan to 1.0.2 (neutron requires >= 1.0.0)
2) Add python-pecan as a dependency to neutron
Comment 1 wes hayutin 2015-09-22 15:55:54 EDT
*** Bug 1265396 has been marked as a duplicate of this bug. ***
Comment 2 Javier Peña 2015-09-22 16:09:02 EDT
The global requirement for pecan was bumped to 1.0.0 at https://review.openstack.org/213085 . This specifically mentions Neutron as a consumer of this version.

A local mock build of the current fedora python-pecan 1.0.2 spec worked fine on f22 and epel7, so it should be relatively straightforward.
Comment 3 David Moreau Simard 2015-09-22 16:21:13 EDT
Submitted dependency for python-pecan in https://review.gerrithub.io/#/c/248028 for neutron.

Asked for help for bumping the version of python-pecan.
Comment 6 David Moreau Simard 2015-09-22 17:04:21 EDT
Sent a new patchset to the neutron package review for jenkins to pick it up. It failed to verify since pecan was not there yet.

Note You need to log in before you can comment on or make changes to this bug.