Bug 1265504 - Asus 550JK brightness cannot be adjusted [NEEDINFO]
Asus 550JK brightness cannot be adjusted
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 02:00 EDT by Turgut Kalfaoglu
Modified: 2015-11-23 12:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 12:10:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jforbes: needinfo?


Attachments (Terms of Use)

  None (edit)
Description Turgut Kalfaoglu 2015-09-23 02:00:22 EDT
Description of problem:

Laptop ASUS 550JK's brightness buttons do not function.
The screen is at maximum brightness.

All other function keys work, however the Fn-F5 and Fn-F6 do not even generate an event according to evemu. xbacklight does not change the lighting.

# ls /sys/class/backlight

is blank.

tried booting with different options found on the net, acpi_osi, video.use_native_backlight, etc, none helped.
Comment 1 Turgut Kalfaoglu 2015-09-23 02:21:41 EDT
Further info:
my /etc/sysconfig/grub contains:
GRUB_CMDLINE_LINUX="nomodeset nouveau.modeset=0 rd.driver.blacklist=nouveau rhgb quiet acpi_osi=''"

I tried replacing acpi_osi=''  with the following so far:
video.use_native_backlight=1
acpi_osi=\"!Windows 2012\"
acpi_osi=\"!Windows 2009\"
acpi_backlight=vendor

I have bumblebee loaded, defaults to the intel card.
I see that asus_nb_wmi  is loaded in lsmod.
Comment 2 Turgut Kalfaoglu 2015-09-28 02:05:35 EDT
While waiting for a reply, I thought I'd add a few things:
1) I recently added SSD to this system, so I re-installed Fedora 22.
 Before the re-install, the hotkeys Fn-F5 and Fn-F6 used to work (with OSD display), and brightness adjustment used to work well.

2) I had nothing in /sys/class/backlight with any options, except, I found out that with this bootline:

linuxefi /boot/vmlinuz-4.1.7-200.fc22.x86_64 root=UUID=16e7d512-f427-454
4-a0fc-5ddacf8a4060 ro nomodeset nouveau.modeset=0 rd.driver.blacklist=nouveau r
hgb quiet  acpi_osi=Linux acpi_backlight=vendor 

..I get asus-nb-wmi listed in /sys/class/backlight:
asus-nb-wmi -> ../../devices/platform/asus-nb-wmi/backlight/asus-nb-wmi
and the target directory contains:

drwxr-xr-x 3 root root    0 Sep 28 08:38 .
drwxr-xr-x 3 root root    0 Sep 28 08:38 ..
-r--r--r-- 1 root root 4096 Sep 28 09:01 actual_brightness
-rw-r--r-- 1 root root 4096 Sep 28 09:01 bl_power
-rw-r--r-- 1 root root 4096 Sep 28 08:38 brightness
lrwxrwxrwx 1 root root    0 Sep 28 09:01 device -> ../../../asus-nb-wmi
-r--r--r-- 1 root root 4096 Sep 28 08:38 max_brightness
drwxr-xr-x 2 root root    0 Sep 28 09:01 power
lrwxrwxrwx 1 root root    0 Sep 28 08:38 subsystem -> ../../../../../class/backlight
-r--r--r-- 1 root root 4096 Sep 28 08:38 type
-rw-r--r-- 1 root root 4096 Sep 28 08:41 uevent

actual_brightness and max_brightness contains 100.
However, echo ??? > brightness does not change the screen brightness, nor the two files I just mentioned.   The hotkeys or OSD still do not function.
Comment 3 Turgut Kalfaoglu 2015-09-30 02:40:12 EDT
I also asked around, so far no good leads.. 
http://forums.fedoraforum.org/showthread.php?p=1744189&posted=1#post1744189

Please feel free to reply to this report at ANY time!
Comment 4 Justin M. Forbes 2015-10-20 15:19:33 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 22 kernel bugs.

Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 23, and are still experiencing this issue, please change the version to Fedora 23.

If you experience different issues, please open a new bug report for those.
Comment 5 Fedora Kernel Team 2015-11-23 12:10:15 EST
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in over 4 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.

Note You need to log in before you can comment on or make changes to this bug.