This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1265508 - katello-installer fails on latest RHEL 7.2 nightly compose
katello-installer fails on latest RHEL 7.2 nightly compose
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SELinux (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: 6.1.4
: --
Assigned To: Lukas Zapletal
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 02:06 EDT by Jan Pazdziora
Modified: 2017-02-23 14:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 15:31:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installer completed successfully in enforcing mode (74.72 KB, image/png)
2015-11-16 03:19 EST, Sachin Ghai
no flags Details

  None (edit)
Description Jan Pazdziora 2015-09-23 02:06:02 EDT
Description of problem:

On RHEL-7.2-20150917.0, Satellite install and configures (katello-installer) fine. On RHEL-7.2-20150921.n.1 it fails.

Version-Release number of selected component (if applicable):

katello-installer-2.3.18-1.el7sat.noarch
selinux-policy-3.13.1-52.el7.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. Install katello-installer and run it.

Actual results:

[31m Could not start Service[httpd]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait start httpd' returned 1: Redirecting to /bin/systemctl start  httpd.service
[0mError: Could not start Service[httpd]: Execution o: 668/669, 99%, 0.7/s, elapsed: 00:06:48, ETA: 00:00:01
[31m /Stage[main]/Apache::Service/Service[httpd]/ensure: change from stopped to running failed: Could not start Service[httpd]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait start httpd' returned 1: Redirecting to /bin/systemctl start  httpd.service

Expected results:

Debug: Executing '/usr/bin/systemctl is-enabled pu: 668/669, 99%, 0.6/s, elapsed: 00:14:17, ETA: 00:00:01
Debug: Executing '/usr/bin/systemctl is-enabled ht: 668/669, 99%, 0.6/s, elapsed: 00:14:18, ETA: 00:00:01

Additional info:
Comment 1 Jan Pazdziora 2015-09-23 02:06:19 EDT
AVC denial listed:

type=SYSCALL msg=audit(1442938965.262:917): arch=c000003e syscall=49 success=no exit=-13 a0=6 a1=7fa9179cb7c0 a2=1c a3=7ffed64b50fc items=0 ppid=1 pid=9141 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="httpd" exe="/usr/sbin/httpd" subj=system_u:system_r:httpd_t:s0 key=(null)
type=AVC msg=audit(1442938965.262:917): avc:  denied  { name_bind } for  pid=9141 comm="httpd" src=5000 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:object_r:commplex_main_port_t:s0 tclass=tcp_socket
Comment 3 Jan Pazdziora 2015-09-23 04:24:10 EDT
Foreman develop started to fail with that selinux-policy as well, albeit with different AVC denial: bug 1265544.
Comment 11 Lukas Pramuk 2015-11-06 05:03:22 EST
it seems to me as a duplicate of BZ #1265544 (caught during installation)...
Comment 14 Mike McCune 2015-11-13 16:25:31 EST
This is solved in: 

https://bugzilla.redhat.com/show_bug.cgi?id=1265544

I'd vote we just close this as a dupe of ^^^^
Comment 16 Sachin Ghai 2015-11-16 03:17:56 EST
Verified with Sat 6.1.4 compose9.

Katello-installer succeed. Please see the attached screenshot. 
I tried rhel7.2 build from beaker (RHEL-7.2-20151106.n.0)
Comment 17 Sachin Ghai 2015-11-16 03:19 EST
Created attachment 1094771 [details]
installer completed successfully in enforcing mode
Comment 18 Bryan Kearney 2015-11-19 15:31:48 EST
This fix was delivered in 6.1.4 on 19 November in https://access.redhat.com/errata/RHBA-2015:2474.

Note You need to log in before you can comment on or make changes to this bug.