Bug 1265523 - When not specified, the default --capsule-dns-provider is wrong
When not specified, the default --capsule-dns-provider is wrong
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 02:47 EDT by Sachin Ghai
Modified: 2017-02-27 10:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-27 10:19:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
foreman-debug (393.71 KB, application/x-xz)
2015-09-23 02:58 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2015-09-23 02:47:35 EDT
Description of problem:
I was trying provision a host on latest upstream build. I installed nightly with katello-deploy. Basically that setup is actually includes Foreman + Katello. 

I was trying to provision a host on libvirt compute-resource and it failed with error:

----------
Unable to save

Create DNS record for shost.lab.eng.pnq.redhat.com task failed with the following error: ERF12-2357 [ProxyAPI::ProxyException]: Unable to set DNS entry ([RestClient::BadRequest]: 400 Bad Request) for proxy https://dhcp207-231.lab.eng.pnq.redhat.com:9090/dns
------------


Version-Release number of selected component (if applicable):
foreman-1.10.0-0.develop.201509180916git04fa19d.el7.noarch
foreman-release-1.10.0-0.develop.201509180916git04fa19d.el7.noarch
foreman-libvirt-1.10.0-0.develop.201509180916git04fa19d.el7.noarch
katello-2.4.0-6.nightly.el7.noarch
katello-installer-base-2.4.0-1.nightly.201509040043gitb37b92b.el7.noarch
katello-installer-2.4.0-1.nightly.201509040043gitb37b92b.el7.noarch


How reproducible:
always

Steps to Reproduce:
1. Provision a host on libvirt
2.
3.

Actual results:
Create DNS record for shost.lab.eng.pnq.redhat.com task failed with the following error: ERF12-2357 [ProxyAPI::ProxyException]: Unable to set DNS entry ([RestClient::BadRequest]: 400 Bad Request) for proxy https://dhcp207-231.lab.eng.pnq.redhat.com:9090/dns

Expected results:
provisioning should succeed.

Additional info:
Comment 7 Sachin Ghai 2015-09-23 02:58 EDT
Created attachment 1076104 [details]
foreman-debug
Comment 9 Dmitri Dolguikh 2015-09-23 05:02:37 EDT
/etc/foreman-proxy/settings.d/dns.yml looks wrong for the current version of smart-proxy. A correct provider is being used, but that's probably because it's the default one. Judging by the error you are getting the key used for for dns zone updates is misconfigured or missing. Check /etc/foreman-proxy/settings.d/dns_nsupdate.yml, make sure 'dns_key' property is set there. Another place to check is /etc/rndc.key: the key name there should correspond to the key name used in /etc/named.conf.
Comment 10 Dmitri Dolguikh 2015-09-23 05:06:11 EDT
Also, check the smart-proxy log around startup -- it will have show default values used for dns and dns_nsupdate modules initialization, might help with troubleshooting of this issue.
Comment 11 Lukas Zapletal 2015-09-23 06:51:33 EDT
I have reproduced this with todays nightly, this is regression. I also see this:

E, [2015-09-23T03:20:01.964664 #27736] ERROR -- : Couldn't enable plugin dns: Unable to find dependency 'nsupdate' of 'dns'.:/usr/share/foreman-proxy/lib/proxy/pluggable.rb:44:in `block in validate_prerequisites_enabled!'
/usr/share/foreman-proxy/lib/proxy/pluggable.rb:42:in `each'
/usr/share/foreman-proxy/lib/proxy/pluggable.rb:42:in `validate_prerequisites_enabled!'
/usr/share/foreman-proxy/lib/proxy/pluggable.rb:38:in `validate!'
/usr/share/foreman-proxy/lib/proxy/plugin.rb:134:in `configure_plugin'
/usr/share/foreman-proxy/lib/proxy/plugin.rb:28:in `block in configure_loaded_plugins'
/usr/share/foreman-proxy/lib/proxy/plugin.rb:28:in `each'
/usr/share/foreman-proxy/lib/proxy/plugin.rb:28:in `configure_loaded_plugins'
/usr/share/foreman-proxy/lib/launcher.rb:101:in `launch'
/usr/share/foreman-proxy/bin/smart-proxy:6:in `<main>'

Sachin can you close this bug and clone this in our RedMine, this should have never been reported on Sat6, there is no Sat6 build at this point with this bug.
Comment 18 Lukas Zapletal 2017-02-24 10:06:54 EST
Upstream closed the ticket, looks like this is misconfiguration. Flipping to installer component for triage, we might backport. I assume this issue is for upgraded instances:

http://projects.theforeman.org/issues/12157
Comment 19 Stephen Benjamin 2017-02-27 10:19:16 EST
I'm going to close this, the linked issue's fix is in Satellite 6.2 since the beginning.

The original issue was reported against nightly 1.10 builds, and it was fixed in #12157 before 1.10 GA.

Note You need to log in before you can comment on or make changes to this bug.