Bug 1265615 - [origin_devexp_552] Pod is pending when adding special ENV to DockerStrategy buildConfig and docker build
[origin_devexp_552] Pod is pending when adding special ENV to DockerStrategy ...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Deployments (Show other bugs)
3.x
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Rodolfo Carvalho
wewang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 07:06 EDT by wewang
Modified: 2015-09-24 02:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 02:12:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wewang 2015-09-23 07:06:58 EDT
Version-Release number of selected component (if applicable):
devenv-fedora_2383
openshift v1.0.6-125-gdc1a7b0
kubernetes v1.1.0-alpha.0-1605-g44c91b1


Description of problem:
when adding ENV(both chinese and english) to DockerStrategy buildConfig and doing docker build, build complete successfully ,but pod is pending 

Steps to Reproduce:
1. Create a project test
   $oc new-project test
2. Edit application-template-dockerbuild.json
a. add env vars to DockerStrategy buildconfig part, for example         
           "env": [
            {
              "name": "PATH",
              "value": "/bin:$PATH"
            }
           ]

3. Process and create the template
   $ oc new-app application-template-dockerbuild.json
4  # oc get builds
   NAME                  TYPE      STATUS     POD
   ruby-sample-build-1   Docker    Complete   ruby-sample-build-1-build
5. Check the pod status
   # oc get pods
   NAME                        READY         STATUS                                                                                                                                                                                           RESTARTS   AGE
database-1-80fon            1/1       Running                                                                                                                                                                                               0          15m
frontend-1-2951u            0/1       Pending                                                                                                                                                                                               0          10m
frontend-1-2se36            0/1       Driver devicemapper failed to create image rootfs 25294ca7ecaf59180634f956a69405608f8bf4119607e9ae191e047a4e84d433: Unknown device c6e6d5e0f8a1e9ccfead71c1accec8207679e9824e73cfef351dfde108cc9dfc   0          10m
ruby-sample-build-1-build   0/1       ExitCode:0    


Actual results:
Pod is pending

Expected results:

Pod is running and can get env value from container
Comment 1 Rodolfo Carvalho 2015-09-23 07:49:16 EDT
" Driver devicemapper failed to create image rootfs 25294ca7ecaf59180634f956a69405608f8bf4119607e9ae191e047a4e84d433: Unknown device c6e6d5e0f8a1e9ccfead71c1accec8207679e9824e73cfef351dfde108cc9dfc"

I think this is unrelated to setting the ENV?

Can you instantiate the sample app using sti, or docker without changing anything from the default template?
Comment 2 wewang 2015-09-24 02:12:20 EDT
Cannot reproduce it now ,so close the bug

Note You need to log in before you can comment on or make changes to this bug.