Bug 1265661 - Packstack does not install Sahara services (RDO Liberty)
Packstack does not install Sahara services (RDO Liberty)
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity high
: ---
: Liberty
Assigned To: Javier Peña
Luigi Toscano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 08:38 EDT by Luigi Toscano
Modified: 2016-03-11 12:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 12:18:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 226778 None None None Never

  None (edit)
Description Luigi Toscano 2015-09-23 08:38:41 EDT
Description of problem:
Set CONFIG_SAHARA_INSTALL=y and start packstack.
The installation completes successfully; /etc/sahara/sahara.conf is configured, but only the packages  python-saharaclient and openstack-sahara-common are installed.

Neither openstack-sahara-api+openstack-sahara-engine (for the new, suggested, split mode) nor openstack-sahara (the deprecated unified service mode) are installed. Those packages contains the daemons and the systemd unit files.

If the packages are manually installed (for example openstack-sahara-api and openstack-sahara-engine), the services start correctly.

Version-Release number of selected component (if applicable):
python-saharaclient-0.10.2-dev13.el7.centos.noarch
openstack-sahara-common-3.0.0.0b4-dev124.el7.centos.noarch

openstack-packstack-2015.2-dev1636.g3015bff.el7.centos.noarch
openstack-packstack-puppet-2015.2-dev1636.g3015bff.el7.centos.noarch
openstack-puppet-modules-2015.2-dev.1150d0da14ad00e6151d11443ab96d6d3e9649b2_8eef2746.el7.centos.noarch
Comment 1 Luigi Toscano 2015-09-23 08:47:01 EDT
Tested on CentOS:
CentOS Linux release 7.1.1503 (Core)
Comment 2 Javier Peña 2015-09-23 09:22:47 EDT
Proposed https://review.openstack.org/226778 with a fix. This was caused by https://review.openstack.org/192721, which slightly changed the way we should consume puppet-sahara.
Comment 3 Luigi Toscano 2016-01-13 09:44:12 EST
As the review above was merged, was this backported to Liberty and included in the official RDO?
Comment 4 Javier Peña 2016-01-13 10:07:52 EST
There was no need to backport to Liberty at the time, as master was still being used for it. I can see the fix is part of openstack-packstack-7.0.0-0.7.dev.dev1661.gaf13b7e
Comment 5 Luigi Toscano 2016-03-11 12:18:48 EST
The issue is now fixed. With both RDO Liberty and the current snapshot of RDO Mitaka, the services
openstack-sahara-api
openstack-sahara-engine
are enabled (from the packages with the same name).

Tested on up-to-date CentOS 7, with:

RDO Liberty: 
openstack-packstack-7.0.0-0.10.dev1682.g42b3426.el7.noarch
openstack-packstack-puppet-7.0.0-0.10.dev1682.g42b3426.el7.noarch
openstack-sahara-api-3.0.0-5.cc218ddgit.el7.noarch
openstack-sahara-engine-3.0.0-5.cc218ddgit.el7.noarch
openstack-sahara-common-3.0.0-5.cc218ddgit.el7.noarch

RDO Mitaka (DLRN snapshot):
openstack-packstack-8.0.0-0.20160303124552.0476b9b.el7.centos.noarch
openstack-packstack-puppet-8.0.0-0.20160303124552.0476b9b.el7.centos.noarch
openstack-sahara-api-4.0.0.0b4-0.20160304033733.6326f6c.el7.centos.noarch
openstack-sahara-common-4.0.0.0b4-0.20160304033733.6326f6c.el7.centos.noarch
openstack-sahara-engine-4.0.0.0b4-0.20160304033733.6326f6c.el7.centos.noarch
python-sahara-4.0.0.0b4-0.20160304033733.6326f6c.el7.centos.noarch

Note You need to log in before you can comment on or make changes to this bug.