Bug 1265721 - FIle /etc/ceilometer/meters.yaml missing
FIle /etc/ceilometer/meters.yaml missing
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-ceilometer (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Liberty
Assigned To: Pradeep Kilambi
Yurii Prokulevych
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 10:29 EDT by Yurii Prokulevych
Modified: 2016-03-30 19:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-ceilometer-5.0.0-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:01:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yurii Prokulevych 2015-09-23 10:29:43 EDT
Description of problem:
File /etc/ceilometer/meters.yaml is missing.
At the meantime file used for the fallback 
/usr/lib/python2.7/site-packages/ceilometer/meter/data/meters.yaml is present.

Version-Release number of selected component (if applicable):
openstack-ceilometer-api-5.0.0.0b4-dev123.el7.centos.noarch
python-ceilometerclient-1.5.1-dev1.el7.centos.noarch
openstack-ceilometer-common-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-collector-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-polling-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-notification-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-central-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-compute-5.0.0.0b4-dev123.el7.centos.noarch
python-ceilometer-5.0.0.0b4-dev123.el7.centos.noarch
openstack-ceilometer-alarm-5.0.0.0b4-dev123.el7.centos.noarch

Additional info:
RHEL 7.1, packstack allinone installation.
Comment 1 Chris Dent 2015-09-23 12:26:40 EDT
Are we intended for meters.yaml to be there? I wasn't clear what we decided.

I guess it makes sense for it to be there so it is easy to customize, but it is not required in any fashion if no customizations are planned. The one in the fallback will always be used.
Comment 2 Pradeep Kilambi 2015-09-23 15:37:36 EDT
 I dont think this is really required, but i can see the advantage, if someone what to update/customize the file it might be hard to find under the python code.

this would be a packaging change where we copy the file from ceilometer/meter/data/meters.yaml to etc/ceilometer in buildroot.
Comment 3 Pradeep Kilambi 2015-09-25 10:08:11 EDT
fix submitted to upstream packaging: https://review.gerrithub.io/248293

Note You need to log in before you can comment on or make changes to this bug.