Bug 1265744 - multiple guests run cyclictest tools cause guest CPU stall
multiple guests run cyclictest tools cause guest CPU stall
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel-rt (Show other bugs)
7.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Clark Williams
Jiri Kastner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 12:07 EDT by FuXiangChun
Modified: 2015-09-24 12:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 12:33:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Luiz Capitulino 2015-09-23 15:42:28 EDT
If you're starting two guests with real-time vCPUs pinned to the same cores in the host, that will deadlock.

Generally speaking, each host core isolated for real-time should run only one real-time vCPU.
Comment 5 FuXiangChun 2015-09-24 12:10:48 EDT
(In reply to Luiz Capitulino from comment #4)
> If you're starting two guests with real-time vCPUs pinned to the same cores
> in the host, that will deadlock.
> 
> Generally speaking, each host core isolated for real-time should run only
> one real-time vCPU.

I see what you mean. I tested this scenario. Both guests work. 

In addition.
 1. Customer also possible to start multiple guests with real-time vCPUs pinned to the same cores in the host. Do we have a relevant way to prevent customer? or let they know the right way. 

 2. Can I use cores do real-time test are not isolated in host?
 
 e.g
cores 1 3 5 7(belong to node1) are isolated in host. vCPUs pinned to these cores. guest1 use them to do real-time test.

cores 0 2 4 6(belong to node0) are not isolated in host. vCPUs pinned to these cores. guest2 use them do do real-time test inside guest.
Comment 6 Luiz Capitulino 2015-09-24 12:33:49 EDT
(In reply to FuXiangChun from comment #5)

> In addition.
>  1. Customer also possible to start multiple guests with real-time vCPUs
> pinned to the same cores in the host. Do we have a relevant way to prevent
> customer? or let they know the right way. 

No, there's no way to prevent this in the real-time kernel. We can write documentation warning about this, but there's no way to prevent it.

>  2. Can I use cores do real-time test are not isolated in host?

You may have higher latency due to other tasks re-activating the tick and/or pushing work to workqueues.

I'm closing this as NOTABUG just to avoid BZs that are not real issues hanging around.

Note You need to log in before you can comment on or make changes to this bug.