Bug 1265756 - Need a way to deploy older commits
Need a way to deploy older commits
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-server-atomic (Show other bugs)
7.2
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Colin Walters
atomic-bugs@redhat.com
: Extras, ZStream
Depends On:
Blocks: 1265975
  Show dependency treegraph
 
Reported: 2015-09-23 13:00 EDT by Colin Walters
Modified: 2016-01-07 15:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: The `atomic host` command now supports a new `deploy` verb Reason: This can be used to switch between specific versions deterministically. See: http://blog.verbum.org/2015/12/15/new-atomic-host-verb-rpm-ostree-deploy/ for a blog entry on this.
Story Points: ---
Clone Of:
: 1265975 (view as bug list)
Environment:
Last Closed: 2015-11-19 09:44:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2015-09-23 13:00:41 EDT
As GSS, support deploying older commits to more easily reproduce customer environments.
Comment 4 Matthew Barnes 2015-10-20 10:16:20 EDT
For 7.2, deploying older commits requires somewhat of a manual process:

  * Identify the <checksum> of the commit to deploy.

  * Your <refspec> might be something like:
    rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
    (use "ostree refs" to list them).

    The <remote> is the part before the colon (rhel-atomic-host-ostree).

  * Issue these ostree commands:

     ostree pull <remote> <checksum>

     ostree reset <refspec> <checksum>

     ostree admin deploy <refspec>

  * Reboot the system into the older commit.

To get back to the latest version, just "atomic host upgrade" and reboot.
Comment 5 Laurie Friedman 2015-10-20 11:09:49 EDT
Is this manual process above sufficient to close this bug?  If so, who needs to close it so that it comes off of the 7.2 blocker list?
Comment 13 errata-xmlrpc 2015-11-19 09:44:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:2468

Note You need to log in before you can comment on or make changes to this bug.