Bug 1265779 - AttributeError: Cannot delete attribute from_repo on <dnf.yum.rpmsack.RPMDBAdditionalDataPackage object at 0x7f1d73dba290>
AttributeError: Cannot delete attribute from_repo on <dnf.yum.rpmsack.RPMDBAd...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 13:54 EDT by Eric Work
Modified: 2015-09-30 13:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 13:38:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Work 2015-09-23 13:54:02 EDT
I did a normal system update using:

$ sudo dnf update --refresh

During the verification step I got the following backtrace:

...
  Verifying   : unzip-6.0-22.fc22.x86_64                                  50/96 
  Verifying   : kernel-headers-4.1.6-201.fc22.x86_64                      51/96 
The downloaded packages were saved in cache till the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 144, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 173, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 224, in do_transaction
    super(BaseCli, self).do_transaction(display)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 604, in do_transaction
    self._run_transaction(cb=cb)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 726, in _run_transaction
    self.verify_transaction(cb.verify_tsi_package)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 840, in verify_transaction
    yumdb_item.clean()
  File "/usr/lib/python2.7/site-packages/dnf/yum/rpmsack.py", line 326, in clean
    self._delete(item)
  File "/usr/lib/python2.7/site-packages/dnf/yum/rpmsack.py", line 288, in _delete
    raise AttributeError("Cannot delete attribute %s on %s " % (attr, self))
AttributeError: Cannot delete attribute from_repo on <dnf.yum.rpmsack.RPMDBAdditionalDataPackage object at 0x7f1d73dba290> 

Running the "dnf update" command again shows there are no updates or other errors.  I'm not sure if there is anything left to complete for the transaction since it already did the update/install and cleanups stages.
Comment 1 Michal Luscon 2015-09-30 05:30:57 EDT
The transaction was successfully completed and if your updated version of DNF is not 1.1.2-2, dnf upgrade --refresh works as expected.

DNF should log this error instead of raising an exception.
Comment 2 Eric Work 2015-09-30 13:38:11 EDT
It looks like dnf 1.1.2 has not yet been pushed to stable, but I haven't seen the problem since this one time.  I'll consider this resolved.  The main reason for filing this bug was just to make the developers aware that it happened.

Note You need to log in before you can comment on or make changes to this bug.