Bug 1265822 - Momentary failure of volume Attach & Detach [NEEDINFO]
Momentary failure of volume Attach & Detach
Status: CLOSED DUPLICATE of bug 1231733
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
urgent Severity urgent
: ---
: 6.0 (Juno)
Assigned To: Eoghan Glynn
nlevinki
: Unconfirmed, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 16:51 EDT by Jeremy
Modified: 2016-04-26 09:23 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-02 05:42:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jraju: needinfo? (eglynn)
jmelvin: needinfo? (eglynn)


Attachments (Terms of Use)

  None (edit)
Description Jeremy 2015-09-23 16:51:54 EDT
Description of problem:



2015-09-23 14:14:53.064 27211 DEBUG neutronclient.client [req-0c74dbd7-d532-4a4f-8cc3-fa122fb5a1e7 ]
2015-09-23 14:14:53.199 27211 DEBUG neutronclient.client [req-0c74dbd7-d532-4a4f-8cc3-fa122fb5a1e7 ] RESP:401 {'content-length': '23', 'www-authenticate': "Keystone uri='http://87.44.1.15:5000/'", 'connection': 'keep-alive', 'date': 'Wed, 23 Sep 2015 14:15:07 GMT', 'content-type': 'text/plain', 'x-openstack-request-id': 'req-de763510-33bb-45d7-9198-3b7627ba3a98'} Authentication required
2015-09-23 14:14:53.201 27211 ERROR nova.api.openstack [req-0c74dbd7-d532-4a4f-8cc3-fa122fb5a1e7 None] Caught error: auth_url was not provided to the Neutron client
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack Traceback (most recent call last):
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/nova/api/openstack/__init__.py", line 124, in __call__
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     return req.get_response(self.application)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/webob/request.py", line 1296, in send
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     application, catch_exc_info=False)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/webob/request.py", line 1260, in call_application
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     app_iter = application(self.environ, start_response)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 144, in __call__
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     return resp(environ, start_response)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token.py", line 748, in __call__
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     return self._call_app(env, start_response)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token.py", line 684, in _call_app
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     return self._app(env, _fake_start_response)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 144, in __call__
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     return resp(environ, start_response)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 144, in __call__
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     return resp(environ, start_response)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/routes/middleware.py", line 131, in __call__
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     response = self.app(environ, start_response)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 144, in __call__
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     return resp(environ, start_response)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     resp = self.call_func(req, *args, **self.kwargs)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     return self.func(req, *args, **kwargs)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/nova/api/openstack/wsgi.py", line 910, in __call__
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     content_type, body, accept)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/nova/api/openstack/wsgi.py", line 1001, in _process_stack
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     request, action_args)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/nova/api/openstack/wsgi.py", line 880, in post_process_extensions
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     **action_args)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/nova/api/openstack/compute/contrib/security_groups.py", line 608, in detail
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     self._extend_servers(req, list(resp_obj.obj['servers']))
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/nova/api/openstack/compute/contrib/security_groups.py", line 557, in _extend_servers
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     servers))
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/nova/network/security_group/neutron_driver.py", line 351, in get_instances_security_groups_bindings
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     security_groups = self._get_secgroups_from_port_list(ports, neutron)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/nova/network/security_group/neutron_driver.py", line 335, in _get_secgroups_from_port_list
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     search_results = neutron.list_security_groups(**sg_search_opts)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 98, in with_params
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     ret = self.function(instance, *args, **kwargs)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 480, in list_security_groups
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     retrieve_all, **_params)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 1334, in list
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     for r in self._pagination(collection, path, **params):
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 1347, in _pagination
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     res = self.get(path, params=params)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 1320, in get
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     headers=headers, params=params)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 1297, in retry_request
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     headers=headers, params=params)
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 1240, in do_request
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     content_type=self.content_type())
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/client.py", line 183, in do_request
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     self.authenticate()
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/client.py", line 247, in authenticate
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     self._authenticate_keystone()
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/neutronclient/client.py", line 220, in _authenticate_keystone
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack     raise exceptions.NoAuthURLProvided()
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack NoAuthURLProvided: auth_url was not provided to the Neutron client
2015-09-23 14:14:53.201 27211 TRACE nova.api.openstack


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Eric Harney 2015-09-23 17:01:29 EDT
I'm pulling the logs to look at this more, but, at first glance, the stack trace above appears to be related to Nova, Neutron, and security groups and not Cinder.
Comment 5 Eoghan Glynn 2015-09-25 06:36:09 EDT
The NoAuthURLProvided aspect looks like a duplicate of:

  https://bugzilla.redhat.com/1231733

Sahid has a backport prepared already:

  https://code.engineering.redhat.com/gerrit/54678

We can expedite landing & building that backport. Do you need a hotfix?
Comment 14 Lee Yarwood 2015-10-02 05:42:49 EDT

*** This bug has been marked as a duplicate of bug 1231733 ***

Note You need to log in before you can comment on or make changes to this bug.