Bug 1265826 - dnf update does nothing; dnf update <package-name> works
dnf update does nothing; dnf update <package-name> works
Status: CLOSED DUPLICATE of bug 1265336
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 17:12 EDT by Daniel Mach
Modified: 2015-09-25 05:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 05:44:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2015-09-23 17:12:14 EDT
I updated dnf to latest version by running:
$ dnf update dnf

then I ran:
$ dnf update
Dependencies resolved.
Nothing to do.
Complete!
(nothing happened)

expected result:
packages are updated

providing package name leads to:
$ dnf update kernel
Dependencies resolved.
=============================================================================================================================================
 Package                            Arch                       Version                            Repository                            Size
=============================================================================================================================================
Installing:
 kernel                             x86_64                     4.2.1-300.fc23                     updates-testing                       45 k
 kernel-core                        x86_64                     4.2.1-300.fc23                     updates-testing                       20 M
 kernel-modules                     x86_64                     4.2.1-300.fc23                     updates-testing                       18 M
Removing:
 kernel-core                        x86_64                     4.0.4-301.fc22                     @updates-testing                      41 M
 kernel-modules                     x86_64                     4.0.4-301.fc22                     @updates-testing                      17 M

Transaction Summary
=============================================================================================================================================
Install  3 Packages
Remove   2 Packages

Total download size: 37 M
Is this ok [y/N]: 


version:
dnf-1.1.2-2.fc23.noarch


Can you give it high priority as it possibly breaks ability to update system once new dnf is installed?
Comment 1 Michael Mráka 2015-09-24 05:32:33 EDT
dnf update
   does not work

dnf update '*'
   works but it takes 8 minutes to resolve updates/deps and a all this time it looks like dnf hangs


dnf-1.1.1-1 works as expected
Comment 2 Michael Mráka 2015-09-25 05:44:24 EDT

*** This bug has been marked as a duplicate of bug 1265336 ***

Note You need to log in before you can comment on or make changes to this bug.