Bug 1265829 - OpenVPN fails to connect after NetworkManager upgrade. [NEEDINFO]
OpenVPN fails to connect after NetworkManager upgrade.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 17:18 EDT by Stefan Seefeld
Modified: 2016-05-06 02:59 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-20 16:23:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ww12z: needinfo? (extras-qa)


Attachments (Terms of Use)

  None (edit)
Description Stefan Seefeld 2015-09-23 17:18:10 EDT
Description of problem:

I'm trying to open an OpenVPN connection. While I'm typing in my credentials, the dialog closes and an (error ?) message appears:
"The service providing the VPN connection was stopped"

Version-Release number of selected component (if applicable):

The problem appeared after I did an upgrade, including a new kernel (4.1.7) as well as various NetworkManager components. The current NetworkManager version is  1.0.6
Comment 1 Stefan Seefeld 2015-09-23 18:04:10 EDT
Using `journalctl -f` I see this line when the error message pops up:

Sep 23 17:47:56 quasimodo NetworkManager[8841]: <info>  VPN service 'openconnect' disappeared

Any idea what might cause this, and how to debug this further ?
Comment 2 Alexander Mayorov 2015-09-24 09:32:46 EDT
Hi All!

  I have the same problem with NetworkManager-openconnect:
  Start connection:
NetworkManager[1097]: <info>  Starting VPN service 'openconnect'...
NetworkManager[1097]: <info>  VPN service 'openconnect' started (org.freedesktop.NetworkManager.openconnect), PID 24283
NetworkManager[1097]: <info>  VPN service 'openconnect' appeared; activating connections
  Directly after credentials have been provided:
NetworkManager[1097]: <info>  VPN service 'openconnect' disappeared
NetworkManager[1097]: <warn>  error disconnecting VPN: The name org.freedesktop.NetworkManager.openconnect was not provided by any .service files

  Unfortunately the new NetworkManager-openconnect plugin compatible with NetworkManager v1.0.6 absent even in fedora22-updates-testing repository up to now, while some other VPN plugins already there during some time (e.g. NetworkManager-openswan, NetworkManager-openvpn, NetworkManager-vpnc) and hopefully will be pushed to fedora22-updates shortly.
Comment 3 Alexander Mayorov 2015-09-26 05:17:14 EDT
Hi All!

  In my case with NetworkManager-openconnect I found that it looks like there is a relatively short timeout (about 15 seconds) started after "switch on" the VPN via NM applet (homing in top right screen corner) and expired during preparation of credentials (generation of one time password). If I'm ready with one time password before click on VPN connection and enter all authentication date rapidly, then it will connect with success.
Comment 4 Štefan Gurský 2015-10-27 11:25:56 EDT
I get (no metion of openconnect).


okt 27 16:17:46 zork NetworkManager[1230]: <info>  Starting VPN service 'openvpn'...
okt 27 16:17:46 zork NetworkManager[1230]: <info>  VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 26723
okt 27 16:17:46 zork NetworkManager[1230]: <info>  VPN service 'openvpn' appeared; activating connections
okt 27 16:17:49 zork audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
okt 27 16:17:50 zork NetworkManager[1230]: <info>  VPN plugin state changed: starting (3)
okt 27 16:17:50 zork NetworkManager[1230]: <info>  VPN service 'openvpn' disappeared
okt 27 16:17:50 zork NetworkManager[1230]: <warn>  error disconnecting VPN: The name org.freedesktop.NetworkManager.openvpn was not provided by any .service files
Comment 5 Jirka Klimes 2015-10-27 12:23:30 EDT
It the problem is a short timeout, that has been fixed upstream:
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=b1512221bc29f24b86d464dc5117439c366fd299
Comment 6 Pavel Moravec 2016-02-24 03:24:15 EST
(In reply to Jirka Klimes from comment #5)
> It the problem is a short timeout, that has been fixed upstream:
> http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/
> ?id=b1512221bc29f24b86d464dc5117439c366fd299

Not sure if just the timeout is the cause. If the timeout was 20 seconds and #c4 shows openvpn disappeared within 4 seconds..?

(confirmed it on my also affected notebook, I typed password within 20s but same output)
Comment 7 Pavel Moravec 2016-02-24 03:35:25 EST
(In reply to Pavel Moravec from comment #6)
> (In reply to Jirka Klimes from comment #5)
> > It the problem is a short timeout, that has been fixed upstream:
> > http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/
> > ?id=b1512221bc29f24b86d464dc5117439c366fd299
> 
> Not sure if just the timeout is the cause. If the timeout was 20 seconds and
> #c4 shows openvpn disappeared within 4 seconds..?
> 
> (confirmed it on my also affected notebook, I typed password within 20s but
> same output)

In my case, this helped:

- delete from /etc/xdg/autostart/nm-applet.desktop the line:
NotShowIn=KDE;GNOME;

- restart NetworkManager service
Comment 8 ww12z 2016-04-20 03:13:51 EDT
(In reply to Pavel Moravec from comment #7)
> (In reply to Pavel Moravec from comment #6)
> > (In reply to Jirka Klimes from comment #5)
> > > It the problem is a short timeout, that has been fixed upstream:
> > > http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/
> > > ?id=b1512221bc29f24b86d464dc5117439c366fd299
> > 
> > Not sure if just the timeout is the cause. If the timeout was 20 seconds and
> > #c4 shows openvpn disappeared within 4 seconds..?
> > 
> > (confirmed it on my also affected notebook, I typed password within 20s but
> > same output)
> 
> In my case, this helped:
> 
> - delete from /etc/xdg/autostart/nm-applet.desktop the line:
> NotShowIn=KDE;GNOME;
> 
> - restart NetworkManager service

This worked for me as well. Thanks, buddy.
Comment 9 Rashid Khan 2016-04-20 12:40:17 EDT
Can we close this BZ now?
Comment 10 Stefan Seefeld 2016-04-20 12:49:18 EDT
No objections from me;  I no longer observe the issue.
Comment 11 Alexander Mayorov 2016-04-20 12:58:53 EDT
I don't observe the issue for long time already.
Comment 12 Rashid Khan 2016-04-20 16:23:06 EDT
Closed as per comment 11 and 10 above
Comment 13 ww12z 2016-05-06 02:59:24 EDT
The issue reappears after applying Pavel Moravec's fix. 
I have commented out that line in /etc/xdg/autostart/nm-applet.desktop and I always have to restart the NetworkManager service.

Note You need to log in before you can comment on or make changes to this bug.