Bug 1265835 - [RFE] Baobab should expect that mountpoints may change after the location is added
[RFE] Baobab should expect that mountpoints may change after the location is ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: baobab (Show other bugs)
7.2
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 17:37 EDT by Vera Budikova
Modified: 2017-10-13 03:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-13 03:56:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 755044 None None None Never

  None (edit)
Description Vera Budikova 2015-09-23 17:37:33 EDT
Description of problem:
Baobab should expect that mountpoints may change after the location is added

Version-Release number of selected component (if applicable):
baobab-3.14.1-5.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Mount several nfs folders
2. Run baobab
3. Scan filesystem
4. Wait a few minutes
5. Mount another nfs folder
6. Click on refresh button

Actual results:
Baobab is frozen, because new mountpoint is not omitted. The baobab application design doesn't expect that mountpoints may change after the location is added.

Expected results:
Baobab is not frozen and mounted folders are omitted.

Additional info:
Comment 2 Ondrej Holy 2015-09-24 02:20:12 EDT
I proposed upstream fix, but it hasn't accepted yet, let's fix it in 7.3.
Comment 3 Ondrej Holy 2016-01-12 09:27:38 EST
The patch has not been accepted by the upstream yet.
Comment 6 Ondrej Holy 2017-10-13 03:56:16 EDT
The patch has been provided to upstream and unfortunately, it lies there without any feedback. Let's close this bug because this is not really anything serious and it doesn't have enough justification to maintain this patch downstream only. Desktop packages are regularly rebased anyway, so the fix will come soon after it is merged upstream...

Note You need to log in before you can comment on or make changes to this bug.