Bug 1265838 - sendmail 32 bit install missing symbolic links missing sendmail.cf dependency
sendmail 32 bit install missing symbolic links missing sendmail.cf dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
21
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-23 17:48 EDT by Mark Hittinger
Modified: 2015-09-30 09:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 09:08:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Hittinger 2015-09-23 17:48:53 EDT
Description of problem:

on 32 bit Fedora 21 a sendmail installation fails to start - a number of
symbolic links are missing.  The sendmail-cf rpm is also not installed as
a dependency on 32 bit.

Version-Release number of selected component (if applicable):

fedora 21 i686 sendmail 8.14.9-6.fc21

How reproducible:

install f21 32 bit, install sendmail, attempt to start sendmail

Steps to Reproduce:
1.
2.
3.

Actual results:

# systemctl status sendmail
* sendmail.service - Sendmail Mail Transport Agent
   Loaded: loaded (/usr/lib/systemd/system/sendmail.service; enabled)
   Active: failed (Result: resources) since Wed 2015-09-23 16:24:05 CDT; 21min ago
  Process: 1391 ExecStart=/usr/sbin/sendmail -bd $SENDMAIL_OPTS $SENDMAIL_OPTARG (code=exited, status=0/SUCCESS)
  Process: 1383 ExecStartPre=/etc/mail/make aliases (code=exited, status=0/SUCCESS)
  Process: 1377 ExecStartPre=/etc/mail/make (code=exited, status=0/SUCCESS)

Sep 23 16:24:05 www32.hlt.utdallas.edu make[1377]: /etc/mail/make: line 22: /usr/bin/makemap: No such file or directory
Sep 23 16:24:05 www32.hlt.utdallas.edu make[1377]: /etc/mail/make: line 22: /usr/bin/makemap: No such file or directory
Sep 23 16:24:05 www32.hlt.utdallas.edu make[1377]: /etc/mail/make: line 22: /usr/bin/makemap: No such file or directory
Sep 23 16:24:05 www32.hlt.utdallas.edu make[1377]: /etc/mail/make: line 22: /usr/bin/makemap: No such file or directory
Sep 23 16:24:05 www32.hlt.utdallas.edu sendmail[1391]: -bd is not supported by sSMTP
Sep 23 16:24:05 www32.hlt.utdallas.edu systemd[1]: PID file /run/sendmail.pid not readable (yet?) after start.
Sep 23 16:24:05 www32.hlt.utdallas.edu systemd[1]: Failed to start Sendmail Mail Transport Agent.
Sep 23 16:24:05 www32.hlt.utdallas.edu systemd[1]: Unit sendmail.service entered failed state.
Sep 23 16:24:05 www32.hlt.utdallas.edu systemd[1]: sendmail.service failed.


Expected results:

#

Additional info:

on a 32 bit fedora 21:
# cd /etc/alternatives; ls -lad mta*
lrwxrwxrwx. 1 root root 24 Sep 23 15:39 mta -> /usr/sbin/sendmail.ssmtp
lrwxrwxrwx. 1 root root 20 Sep 23 15:39 mta-mailq -> /usr/bin/mailq.ssmtp
lrwxrwxrwx. 1 root root 36 Sep 23 15:39 mta-mailqman -> /usr/share/man/man8/mailq.ssmtp.8.gz
lrwxrwxrwx. 1 root root 25 Sep 23 15:39 mta-newaliases -> /usr/bin/newaliases.ssmtp
lrwxrwxrwx. 1 root root 41 Sep 23 15:39 mta-newaliasesman -> /usr/share/man/man8/newaliases.ssmtp.8.gz
lrwxrwxrwx. 1 root root 30 Sep 23 15:39 mta-sendmailman -> /usr/share/man/man8/ssmtp.8.gz
# cd /sbin; ls -lad makemap*
-rwxr-xr-x. 1 root root 96632 May 28 05:28 makemap.sendmail

vs a 64 bit fedora 21:
# cd /etc/alternatives; ls -lad mta*
lrwxrwxrwx 1 root root 27 Sep 23 09:14 mta -> /usr/sbin/sendmail.sendmail
lrwxrwxrwx 1 root root 41 Sep 23 09:14 mta-aliasesman -> /usr/share/man/man5/aliases.sendmail.5.gz
lrwxrwxrwx 1 root root 23 Sep 23 09:14 mta-mailq -> /usr/bin/mailq.sendmail
lrwxrwxrwx 1 root root 39 Sep 23 09:14 mta-mailqman -> /usr/share/man/man1/mailq.sendmail.1.gz
lrwxrwxrwx 1 root root 26 Sep 23 09:14 mta-makemap -> /usr/sbin/makemap.sendmail
lrwxrwxrwx 1 root root 41 Sep 23 09:14 mta-makemapman -> /usr/share/man/man8/makemap.sendmail.8.gz
lrwxrwxrwx 1 root root 28 Sep 23 09:14 mta-newaliases -> /usr/bin/newaliases.sendmail
lrwxrwxrwx 1 root root 44 Sep 23 09:14 mta-newaliasesman -> /usr/share/man/man1/newaliases.sendmail.1.gz
lrwxrwxrwx 1 root root 24 Sep 23 09:14 mta-pam -> /etc/pam.d/smtp.sendmail
lrwxrwxrwx 1 root root 23 Sep 23 09:14 mta-rmail -> /usr/bin/rmail.sendmail
lrwxrwxrwx 1 root root 39 Sep 23 09:14 mta-rmailman -> /usr/share/man/man8/rmail.sendmail.8.gz
lrwxrwxrwx 1 root root 26 Sep 23 09:14 mta-sendmail -> /usr/lib/sendmail.sendmail
lrwxrwxrwx 1 root root 42 Sep 23 09:14 mta-sendmailman -> /usr/share/man/man8/sendmail.sendmail.8.gz
# cd /sbin; ls -lad makemap*
lrwxrwxrwx 1 root root    29 Sep 23 09:14 makemap -> /etc/alternatives/mta-makemap
-rwxr-xr-x 1 root root 98048 May 28 05:27 makemap.sendmail
Comment 1 Jaroslav Škarvada 2015-09-24 04:14:10 EDT
Fedora is no MTA. It seems your current MTA is ssmtp. It was probably installed by some dependency, it is not in the current comps (AFAIK) for default installation. To use different MTA, e.g. sendmail, you need to install it and setup it through alternatives (there could be only one active MTA at the time):

# dnf install sendmail
# alternatives --config mta

Regarding sendmail-cf it has never been dependency. It is optional. You need it only if you change m4 configuration (recommended way of sendmail configuration). It is not required if you use default configuration or if you use your own sendmail.cf or configure sendmail through cf (not recommended).
Comment 2 Jaroslav Škarvada 2015-09-24 04:57:28 EDT
Could you find out what brought ssmtp in?

# rpm -q --whatrequires ssmtp
Comment 3 Jaroslav Škarvada 2015-09-24 05:42:37 EDT
I tried default installation of all:

workstation
cloud
server
nonproduct

variants, nothing brought ssmtp in.
Comment 4 Jaroslav Škarvada 2015-09-24 05:50:19 EDT
Also:

# dnf repoquery --whatrequires ssmtp

revealed nothing.

Haven't you installed ssmtp manually and switched off the alternatives automode? In automode (the default) the sendmail has priority over ssmtp in alternatives. Ssmtp has priority 30, sendmail 90, it means:

# dnf install ssmtp
# dnf install sendmail

or

# dnf install sendmail
# dnf install ssmtp

in both cases:

# alternatives --display mta | head
mta - status is auto.
 link currently points to /usr/sbin/sendmail.sendmail
Comment 5 Mark Hittinger 2015-09-24 16:26:44 EDT
Thanks guys - I set up two VM's one 64 bit and one 32 bit using the Fedora-Server DVD.  After install I did a series of groupinstalls on groups I am
interested in.

As a final step I installed sendmail on both and attempted to start sendmail.
On the 64 bit VM I got the expected results but on the 32 bit things did not
behave as expected.

I am going to look at my groupinstall list and see if that is perhaps where
ssmtp was pulled in on the 32 bit side.

on the 32 bit Fedora 21 VM:

# rpm -q --whatrequires ssmtp
no package requires ssmtp

# alternatives --display mta | head
mta - status is manual.
 link currently points to /usr/sbin/sendmail.ssmtp
/usr/sbin/sendmail.ssmtp - priority 30
 slave mta-pam: (null)
 slave mta-mailq: /usr/bin/mailq.ssmtp
 slave mta-newaliases: /usr/bin/newaliases.ssmtp
 slave mta-rmail: (null)
 slave mta-sendmail: (null)
 slave mta-makemap: (null)
 slave mta-mailqman: /usr/share/man/man8/mailq.ssmtp.8.gz

and the group list from 32 bit side:
Installed groups:
   Administration Tools
   C Development Tools and Libraries
   Development Tools
   Engineering and Scientific
   RPM Development Tools
   Security Lab
   System Tools

# rpm -qi ssmtp
Group       : Applications/Internet
Comment 6 Mark Hittinger 2015-09-24 17:35:05 EDT
just did a quick install of a 32 bit fedora VM from the
Fedora-Server-DVD-i386-21.iso

ssmtp was installed as part of the initial install.
Comment 7 Jaroslav Škarvada 2015-09-25 04:47:21 EDT
Thanks for info, I will check. What I still cannot understand is what set alternatives for MTA to 'manual' mode (i.e. 'mta - status is manual' line).
Comment 8 Jaroslav Škarvada 2015-09-25 10:28:18 EDT
It seems smartmontools explicitly required /usr/sbin/sendmail. This requirement was resolved by yum on the 'first-match-taken' basis, so it brought in ssmtp as one of the providers. The smartmontools package is in the 'standard' group, thus it got installed on the server by default.

It seems the sendmail requirement was fixed in smartmontools-6.3-3, but the installation image you noted in comment 6 is generated with the old smartmontools package. I think you could overcome this problem by enabling the update repository during the installation. Otherwise this problem is unfixable, because refresh of the installation media near the product end is unlikely.

Nevertheless I cannot understand why you ended up with MTA alternatives set to manual mode. Even by installing Fedora from the media noted in comment 6, my MTA alternatives are still set in auto mode and just doing:

# yum install sendmail

results in sendmail correctly taking over ssmtp.

Please let me know if you find reproducer for this issue, otherwise I am going to close this bug.
Comment 9 Mark Hittinger 2015-09-25 17:14:54 EDT
Ok to close since it is easy to recover from with "alternatives --config mta"

thanks guys!
Comment 10 Jaroslav Škarvada 2015-09-30 09:08:32 EDT
Ok, thanks for info, closing as CURRENTRELEASE, because the problem shouldn't happen with up-to date packages.

Note You need to log in before you can comment on or make changes to this bug.