Bug 126587 - RFE: yum needs a --download option similar to up2date
RFE: yum needs a --download option similar to up2date
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-23 12:16 EDT by Scott R. Godin
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-06 08:21:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott R. Godin 2004-06-23 12:16:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040612 Firefox/0.8

Description of problem:
yum should have available a download-only option similar to how
up2date will allow you to download but not install a package.

In addition, it would be nice to have a download-src option to instead
get the src.rpm; if such a thing is possible, such functionality could
potentially be added at the same time.

Version-Release number of selected component (if applicable):
yum-2.0.5-1

How reproducible:
Always

Steps to Reproduce:
1. attempt to download-but-not-install a package via yum
2. attempt to grab the src rpms via yum
    

Additional info:
Comment 1 Seth Vidal 2004-06-23 12:19:34 EDT
yum has one.

yum --help

I believe it's been in there since yum 2.0.6

the source downloading is outside of the scope of yum 2.0.X.

it may be included in a future version.
Comment 2 Scott R. Godin 2004-06-23 13:12:51 EDT
ahh if it's in a version later than that supplied to Fedora Core 1,
then I wouldn't have seen it yet. Guess I should look around and grab
the latest. 

Note You need to log in before you can comment on or make changes to this bug.