Bug 1265940 - Hard lock up on Lenovo Thinkpad t440s
Hard lock up on Lenovo Thinkpad t440s
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 04:01 EDT by Alexander Bokovoy
Modified: 2016-09-23 16:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-23 16:15:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Bokovoy 2015-09-24 04:01:26 EDT
Description of problem:

After upgrade to Fedora 23,  kernel started to produce following 'warning' which leads in few seconds to hard lock up and forces to completely reboot the machine. It happens at least twice a day, making the system very unstable.

I saw several other bugs were filed against Rawhide for similar lock ups but none against F23.

Sep 23 21:16:24 onega.vda.li kernel: ------------[ cut here ]------------
Sep 23 21:16:24 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Sep 23 21:16:24 onega.vda.li kernel: Info: mapping multiple BARs. Your kernel is fine.
Sep 23 21:16:24 onega.vda.li kernel: Modules linked in:
Sep 23 21:16:24 onega.vda.li kernel: 
Sep 23 21:16:24 onega.vda.li kernel: CPU: 1 PID: 1 Comm: swapper/0 Not tainted 4.2.0-300.fc23.x86_64 #1
Sep 23 21:16:24 onega.vda.li kernel: Hardware name: LENOVO 20ARS19C05/20ARS19C05, BIOS GJET75WW (2.25 ) 03/28/2014
Sep 23 21:16:24 onega.vda.li kernel:  0000000000000000 00000000d380476a ffff88030fdb7a78 ffffffff817712aa
Sep 23 21:16:24 onega.vda.li kernel:  0000000000000000 ffff88030fdb7ad0 ffff88030fdb7ab8 ffffffff8109e466
Sep 23 21:16:24 onega.vda.li kernel:  ffff88030fdb7ae8 00000000fed10000 ffffc900018c8000 0000000000006000
Sep 23 21:16:24 onega.vda.li kernel: Call Trace:
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff817712aa>] dump_stack+0x45/0x57
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff8109e466>] warn_slowpath_common+0x86/0xc0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff8109e4f5>] warn_slowpath_fmt+0x55/0x70
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81065ba5>] __ioremap_caller+0x2c5/0x380
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81065c77>] ioremap_nocache+0x17/0x20
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81039bf9>] snb_uncore_imc_init_box+0x79/0xb0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff810383a4>] uncore_pci_probe+0xd4/0x1a0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff813e5be5>] local_pci_probe+0x45/0xa0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff8129a49d>] ? sysfs_do_create_link_sd.isra.2+0x6d/0xb0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff813e6ddd>] pci_device_probe+0xed/0x140
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff814d00c4>] driver_probe_device+0x1f4/0x450
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff814d03b0>] __driver_attach+0x90/0xa0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff814d0320>] ? driver_probe_device+0x450/0x450
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff814cdb8c>] bus_for_each_dev+0x6c/0xc0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff814cf8ce>] driver_attach+0x1e/0x20
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff814cf41b>] bus_add_driver+0x1eb/0x280
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81d65149>] ? uncore_cpu_setup+0x12/0x12
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff814d0c20>] driver_register+0x60/0xe0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff813e54cc>] __pci_register_driver+0x4c/0x50
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81d6521b>] intel_uncore_init+0xd2/0x2be
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81d65149>] ? uncore_cpu_setup+0x12/0x12
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81002123>] do_one_initcall+0xb3/0x200
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff810bbe91>] ? parse_args+0x271/0x4a0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81777600>] ? ldsem_down_write+0xd0/0x199
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81d571dc>] kernel_init_freeable+0x18e/0x228
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81767a00>] ? rest_init+0x80/0x80
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81767a0e>] kernel_init+0xe/0xe0
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff8177809f>] ret_from_fork+0x3f/0x70
Sep 23 21:16:24 onega.vda.li kernel:  [<ffffffff81767a00>] ? rest_init+0x80/0x80
Sep 23 21:16:24 onega.vda.li kernel: ---[ end trace e7f6d9c2fabac8fd ]---
Comment 1 Alexander Bokovoy 2015-09-24 09:55:37 EDT
It looks like I have this warning since August:

# journalctl -t kernel |grep 'ioremap_caller+'
Aug 02 20:22:05 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:202 __ioremap_caller+0x2b0/0x3a0()
Aug 02 20:22:05 onega.vda.li kernel:  [<ffffffff81069340>] __ioremap_caller+0x2b0/0x3a0
Aug 06 10:30:13 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:202 __ioremap_caller+0x2b0/0x3a0()
Aug 06 10:30:13 onega.vda.li kernel:  [<ffffffff81069340>] __ioremap_caller+0x2b0/0x3a0
Aug 07 14:46:37 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:202 __ioremap_caller+0x2b0/0x3a0()
Aug 07 14:46:37 onega.vda.li kernel:  [<ffffffff81069340>] __ioremap_caller+0x2b0/0x3a0
Aug 07 14:56:56 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:202 __ioremap_caller+0x2b0/0x3a0()
Aug 07 14:56:56 onega.vda.li kernel:  [<ffffffff81069340>] __ioremap_caller+0x2b0/0x3a0
Aug 07 15:23:37 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:202 __ioremap_caller+0x2b0/0x3a0()
Aug 07 15:23:37 onega.vda.li kernel:  [<ffffffff81069340>] __ioremap_caller+0x2b0/0x3a0
Sep 18 08:54:10 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:202 __ioremap_caller+0x2b0/0x3a0()
Sep 18 08:54:10 onega.vda.li kernel:  [<ffffffff81069340>] __ioremap_caller+0x2b0/0x3a0
Sep 19 14:19:53 onega.vda.li kernel: WARNING: CPU: 0 PID: 1 at arch/x86/mm/ioremap.c:202 __ioremap_caller+0x2b0/0x3a0()
Sep 19 14:19:53 onega.vda.li kernel:  [<ffffffff81069340>] __ioremap_caller+0x2b0/0x3a0
Sep 19 14:39:46 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Sep 19 14:39:46 onega.vda.li kernel:  [<ffffffff81065ba5>] __ioremap_caller+0x2c5/0x380
Sep 19 19:12:59 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Sep 19 19:12:59 onega.vda.li kernel:  [<ffffffff81065ba5>] __ioremap_caller+0x2c5/0x380
Sep 19 19:19:25 onega.vda.li kernel: WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Sep 19 19:19:25 onega.vda.li kernel:  [<ffffffff81065ba5>] __ioremap_caller+0x2c5/0x380
Sep 19 19:22:43 onega.vda.li kernel: WARNING: CPU: 0 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Sep 19 19:22:43 onega.vda.li kernel:  [<ffffffff81065ba5>] __ioremap_caller+0x2c5/0x380

First time it crashed was actually on August 07th, just couple hours before my talk at GUADEC. On September 18th I've upgraded to Fedora 23 and it started to lock up several times.
Comment 2 Pavel Studeník 2015-10-12 07:11:27 EDT
I received following traceback on Fedora-21 Server x86_64

Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz 
Platform: DigitalOffice CPU: SandyBridge D2

Checking dmesg for specific failures!
[    0.371583] ------------[ cut here ]------------
[    0.371824] WARNING: CPU: 2 PID: 1 at arch/x86/mm/ioremap.c:202 __ioremap_caller+0x2aa/0x3a0()
[    0.372260] Info: mapping multiple BARs. Your kernel is fine.
[    0.372554] Modules linked in:

[    0.372743] CPU: 2 PID: 1 Comm: swapper/0 Not tainted 4.1.8-100.fc21.x86_64 #1
[    0.373109] Hardware name: Intel Corporation SandyBridge Platform/LosLunas CRB, BIOS ASNBCPT1.86C.0061.P00.1101131110 01/13/2011
[    0.373704]  0000000000000000 000000008c3fee75 ffff8801493d3a98 ffffffff81792065
[    0.374117]  0000000000000000 ffff8801493d3af0 ffff8801493d3ad8 ffffffff810a163a
[    0.374531]  ffff8801493d3b08 ffffc90000740000 00000000fed16000 0000000000006000
[    0.374943] Call Trace:
[    0.375078]  [<ffffffff81792065>] dump_stack+0x45/0x57
[    0.375342]  [<ffffffff810a163a>] warn_slowpath_common+0x8a/0xc0
[    0.375654]  [<ffffffff810a16c5>] warn_slowpath_fmt+0x55/0x70
[    0.375947]  [<ffffffff810693ba>] __ioremap_caller+0x2aa/0x3a0
[    0.376246]  [<ffffffff810694c7>] ioremap_nocache+0x17/0x20
[    0.376542]  [<ffffffff8103c1bc>] snb_uncore_imc_init_box+0x7c/0xc0
[    0.376864]  [<ffffffff8103a5c3>] uncore_pci_probe+0xd3/0x1c0
[    0.377159]  [<ffffffff813f6da5>] local_pci_probe+0x45/0xa0
[    0.377449]  [<ffffffff812a8da2>] ? sysfs_do_create_link_sd.isra.2+0x72/0xc0
[    0.377807]  [<ffffffff813f8109>] pci_device_probe+0xf9/0x150
[    0.378102]  [<ffffffff814e7e59>] driver_probe_device+0x209/0x4b0
[    0.378417]  [<ffffffff814e81db>] __driver_attach+0x9b/0xa0
[    0.378703]  [<ffffffff814e8140>] ? __device_attach+0x40/0x40
[    0.378999]  [<ffffffff814e5973>] bus_for_each_dev+0x73/0xc0
[    0.379289]  [<ffffffff814e772e>] driver_attach+0x1e/0x20
[    0.379575]  [<ffffffff814e72e0>] bus_add_driver+0x180/0x250
[    0.379865]  [<ffffffff81d72f6a>] ? uncore_cpu_setup+0x12/0x12
[    0.380164]  [<ffffffff814e89d4>] driver_register+0x64/0xf0
[    0.380458]  [<ffffffff813f662c>] __pci_register_driver+0x4c/0x50
[    0.380770]  [<ffffffff81d73032>] intel_uncore_init+0xc8/0x2b4
[    0.381068]  [<ffffffff81d72f6a>] ? uncore_cpu_setup+0x12/0x12
[    0.381366]  [<ffffffff81002148>] do_one_initcall+0xd8/0x210
[    0.381661]  [<ffffffff81d651d1>] kernel_init_freeable+0x18a/0x226
[    0.381976]  [<ffffffff81788450>] ? rest_init+0x80/0x80
[    0.382244]  [<ffffffff8178845e>] kernel_init+0xe/0xf0
[    0.382519]  [<ffffffff81798d22>] ret_from_fork+0x42/0x70
[    0.382796]  [<ffffffff81788450>] ? rest_init+0x80/0x80
[    0.383068] ---[ end trace 7965df4fcf585d76 ]---

End of log.
Comment 3 Laura Abbott 2016-09-23 15:38:53 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 4 Alexander Bokovoy 2016-09-23 16:15:11 EDT
Not reproducible anymore.

Note You need to log in before you can comment on or make changes to this bug.