Bug 126600 - texinfo is missing build dependency
Summary: texinfo is missing build dependency
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-23 17:54 UTC by Steve Grubb
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 4.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 09:45:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Grubb 2004-06-23 17:54:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
texinfo is missing build dependency:

--- working/texinfo/texinfo.spec        2004-02-21 12:45:17.000000000
-0500
+++ /opt/specs/texinfo.spec     2004-05-19 14:25:25.000000000 -0400
@@ -12,7 +12,8 @@
 Prereq: /sbin/install-info
 Prefix: %{_prefix}
 Buildroot: %{_tmppath}/%{name}-%{version}-root
-BuildRequires: zlib-devel
+Requires: zlib, ncurses
+BuildRequires: zlib-devel, ncurses-devel
                                                                     
          
                                                                     
          
 # Redifine this to "dir" in the info directory isn't compressed

Version-Release number of selected component (if applicable):
texinfo-4.6-4

How reproducible:
Always

Steps to Reproduce:
1. rpm -e --nodeps ncurses-devel
2. rpmbuild -bb /usr/src/redhat/SPECS/texinfo.spec

Additional info:

Comment 1 Tim Waugh 2004-06-28 09:45:39 UTC
There is no need for 'Requires: zlib, ncurses', since these library
dependencies are detected automatically at RPM build time.  But I'll
add ncurses-devel to BuildRequires.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.