Bug 1266018 - [fork][origin_userinterface_522] Show unsuitable page when input create/next url directly on web console
[fork][origin_userinterface_522] Show unsuitable page when input create/next ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Fabiano Franz
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 06:24 EDT by Yanping Zhang
Modified: 2016-05-12 13:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:10:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nonexistapp (122.46 KB, image/png)
2015-09-24 06:25 EDT, Yanping Zhang
no flags Details
appname (122.12 KB, image/png)
2015-09-24 21:38 EDT, Yanping Zhang
no flags Details
noappname (120.85 KB, image/png)
2015-09-24 21:43 EDT, Yanping Zhang
no flags Details

  None (edit)
Description Yanping Zhang 2015-09-24 06:24:34 EDT
Description of problem:
Login openshift web console, access create/next page of a existing project with non-existing app name, it will jump to a page showing "Completed", eg: input a url like "https://ec2-52-23-214-214.compute-1.amazonaws.com:8443/console/project/prozyp3/create/next?name=nonexistapp" or "https://ec2-52-23-214-214.compute-1.amazonaws.com:8443/console/project/prozyp3/create/next"

Version-Release number of selected component (if applicable):
openshift v1.0.6-140-g54ba1c1
kubernetes v1.1.0-alpha.0-1605-g44c91b1
fork_ami_openshift3_userinterface_public_522_91

How reproducible:
Always

Steps to Reproduce:
1.Create a project "prozyp3".
2.Login web console, then input and enter the url:
https://ec2-52-23-214-214.compute-1.amazonaws.com:8443/console/project/prozyp3/create/next?name=nonexistapp
3.

Actual results:
2.It shows page with "Completed" context, refer to attachment.

Expected results:
2.It should return to the homepage, or inform user "You haven't created anything"

Additional info:
Comment 1 Yanping Zhang 2015-09-24 06:25 EDT
Created attachment 1076445 [details]
nonexistapp
Comment 2 Yanping Zhang 2015-09-24 21:38 EDT
Created attachment 1076834 [details]
appname
Comment 3 Yanping Zhang 2015-09-24 21:42:58 EDT
Tested on image: fork_ami_openshift3_userinterface_public_522_96
openshift v1.0.6-155-gae636b1
kubernetes v1.1.0-alpha.0-1605-g44c91b1
When access url "https://54.173.68.222:8443/console/project/pro1/create/next?", it will return to overview page.
But when access url "https://54.173.68.222:8443/console/project/pro1/create/next?name" or url "https://54.173.68.222:8443/console/project/pro1/create/next?name=nonexistapp", it still jumps to nextstep page. Pls refer to the attachment "appname" and "noappname".
Comment 4 Yanping Zhang 2015-09-24 21:43 EDT
Created attachment 1076835 [details]
noappname
Comment 5 Yanping Zhang 2015-09-27 23:13:03 EDT
Tested on devenv-fedora_2411
$ openshift version
openshift v1.0.6-188-g347cf33
kubernetes v1.1.0-alpha.0-1605-g44c91b1

When access url like below, it will all jumps to overview page now.
https://54.88.140.137:8443/console/project/prozyp/create/next
https://54.88.140.137:8443/console/project/prozyp/create/next?name
https://54.88.140.137:8443/console/project/prozyp/create/next?name=noapp

The bug is fixed now, pls move it to ON_QA, so QE could verify it. Thanks!
Comment 6 Yanping Zhang 2016-01-10 23:03:11 EST
Checked on latest origin code. Since the bug has been fixed, move it to Verified.

Note You need to log in before you can comment on or make changes to this bug.