Bug 126602 - library conflicts when yum update attempted
library conflicts when yum update attempted
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc34 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-23 14:03 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 14:19:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-06-23 14:03:16 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. yum update l\*
2.
3.
  
Actual results:
Running test transaction:
Errors reported doing trial run
file /usr/lib/debug/usr/bin/c++filt.debug from install of
gcc-debuginfo-3.4.0-6 conflicts with file from package
compat-gcc-debuginfo-8-3.3.3.7
file /usr/lib/debug/usr/bin/cpp.debug from install of
gcc-debuginfo-3.4.0-6 conflicts with file from package
compat-gcc-debuginfo-8-3.3.3.7
file /usr/lib/debug/usr/bin/i386-redhat-linux-gcj.debug from install
of gcc-debuginfo-3.4.0-6 conflicts with file from package
compat-gcc-debuginfo-8-3.3.3.7
file /usr/lib/debug/usr/bin/protoize.debug from install of
gcc-debuginfo-3.4.0-6 conflicts with file from package
compat-gcc-debuginfo-8-3.3.3.7
file /usr/lib/debug/usr/bin/unprotoize.debug from install of
gcc-debuginfo-3.4.0-6 conflicts with file from package
compat-gcc-debuginfo-8-3.3.3.7
file /usr/lib/debug/usr/lib/libffi-2.00-beta.so.debug from install of
gcc-debuginfo-3.4.0-6 conflicts with file from package
compat-gcc-debuginfo-8-3.3.3.7
file /usr/lib/debug/usr/lib/libg2c.so.0.0.0.debug from install of
gcc-debuginfo-3.4.0-6 conflicts with file from package
compat-gcc-debuginfo-8-3.3.3.7
file /usr/lib/debug/usr/lib/libobjc.so.1.0.0.debug from install of
gcc-debuginfo-3.4.0-6 conflicts with file from package
compat-gcc-debuginfo-8-3.3.3.7
[root@hoho2 user1]#


Expected results:


Additional info:
Comment 1 Bob Gustafson 2004-06-23 14:19:02 EDT
That was yum update g\*

I fixed it by removing the package

rpm -e compat-gcc-debuginfo

And then when I redid the yum update g\*
it completed successfully

Works for me

Note You need to log in before you can comment on or make changes to this bug.