Bug 1266059 - system-config-linux won't start, no module named gtk.glade (GTK 3 problem?)
system-config-linux won't start, no module named gtk.glade (GTK 3 problem?)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Lautrbach
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 08:05 EDT by Michael
Modified: 2015-10-11 12:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: policycoreutils-2.4-14.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-11 12:03:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael 2015-09-24 08:05:37 EDT
Description of problem:

dnf install policycoreutils-gui
 (installs fine)
system-config-selinux
  (won't start, see error message)

/usr/share/system-config-selinux/system-config-selinux.py:27: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 33, in <module>
    import Gtk.glade
ImportError: No module named Gtk.glade

Version-Release number of selected component (if applicable):

Fedora 23 Beta with all updates installed as of Sep 24th 2015
Comment 1 Guillaume Kulakowski 2015-10-06 01:58:20 EDT
Same issue with :
root@stargazer ~> rpm -qa G policy
policycoreutils-python3-2.4-13.fc23.x86_64
selinux-policy-devel-3.13.1-147.fc23.noarch
selinux-policy-targeted-3.13.1-147.fc23.noarch
checkpolicy-2.4-1.fc23.1.x86_64
policycoreutils-devel-2.4-13.fc23.x86_64
policycoreutils-gui-2.4-13.fc23.x86_64
policycoreutils-python-2.4-13.fc23.x86_64
policycoreutils-2.4-13.fc23.x86_64
policycoreutils-python-utils-2.4-13.fc23.x86_64
selinux-policy-3.13.1-147.fc23.noarch
Comment 2 Fedora Update System 2015-10-08 06:40:15 EDT
policycoreutils-2.4-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2740460fcc
Comment 3 Fedora Update System 2015-10-09 09:56:00 EDT
policycoreutils-2.4-14.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update policycoreutils'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2740460fcc
Comment 4 Fedora Update System 2015-10-11 12:03:19 EDT
policycoreutils-2.4-14.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.