This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1266091 - NPE when no CPU Type is specified for cluster
NPE when no CPU Type is specified for cluster
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Eli Mesika
Pavel Stehlik
infra
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 08:54 EDT by Tomer Saban
Modified: 2016-05-05 01:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 10:18:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑4.0.0?
rule-engine: blocker?
rule-engine: planning_ack?
oourfali: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)
Engine log with the NPE. (158.95 KB, text/plain)
2015-09-24 08:54 EDT, Tomer Saban
no flags Details

  None (edit)
Description Tomer Saban 2015-09-24 08:54:22 EDT
Created attachment 1076536 [details]
Engine log with the NPE.

Description of problem:
When editing cluster and no "CPU Type" is specified a Null Pointer Exception is thrown instead of giving an error message.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Run clean version of engine.
2.Go to Clusters tab.
3.Click "Edit" on "Default" cluster.
4.Click OK(Don't change the CPU Type. It should be blank).

Actual results:
Edit dialog doesn't close but no error message specified in UI. In the engine.log you may see that NullPointerException was thrown.

Expected results:
Error message should appear saying: "No CPU Type specified".

Additional info:
Comment 1 Yaniv Kaul 2015-09-24 09:10:37 EDT
Tomer:
1. Please (next time) post the NPE stack trace (first few lines) within the bug. It provides the developer a quick way to try and get a hint where the issue is, and it allows easier search for duplicates.
Example:
2015-09-24 15:46:29,168 ERROR [org.ovirt.engine.core.bll.GetClusterEditWarningsQuery] (default task-27) [] Query 'GetClusterEditWarningsQuery' failed: null
2015-09-24 15:46:29,168 ERROR [org.ovirt.engine.core.bll.GetClusterEditWarningsQuery] (default task-27) [] Exception: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.UnsupportedVmCpuClusterEditChecker.isApplicable(UnsupportedVmCpuClusterEditChecker.java:23) [bll.jar:]
	at org.ovirt.engine.core.bll.UnsupportedVmCpuClusterEditChecker$Proxy$_$$_WeldClientProxy.isApplicable(Unknown Source) [bll.jar:]
	at org.ovirt.engine.core.bll.GetClusterEditWarningsQuery.getApplicableChecks(GetClusterEditWarningsQuery.java:100) [bll.jar:]
	at org.ovirt.engine.core.bll.GetClusterEditWarningsQuery.getProblematicEntities(GetClusterEditWarningsQuery.java:74) [bll.jar:]
	at org.ovirt.engine.core.bll.GetClusterEditWarningsQuery.executeQueryCommand(GetClusterEditWarningsQuery.java:56) [bll.jar:]
	at org.ovirt.engine.core.bll.QueriesCommandBase.executeCommand(QueriesCommandBase.java:100) [bll.jar:]
	at org.ovirt.engine.core.dal.VdcCommandBase.execute(VdcCommandBase.java:33) [dal.jar:]
	at org.ovirt.engine.core.bll.Backend.runQueryImpl(Backend.java:539) [bll.jar:]
	at org.ovirt.engine.core.bll.Backend.runQuery(Backend.java:513) [bll.jar:]
	at sun.reflect.GeneratedMethodAccessor76.invoke(Unknown Source) [:1.7.0_79]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_79]
	at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_79]
	at org.jboss.as.ee.component.ManagedReferenceMethodInterceptor.processInvocation(ManagedReferenceMethodInterceptor.java:52)
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:309)
	at org.jboss.invocation.WeavedInterceptor.processInvocation(WeavedInterceptor.java:53)
	at org.jboss.as.ee.component.interceptors.UserInterceptorFactory$1.processInvocation(UserInterceptorFactory.java:63)
	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:309)
	at org.jboss.invocation.InterceptorContext$Invocation.proceed(InterceptorContext.java:407)
	at org.jboss.as.weld.ejb.Jsr299BindingsInterceptor.delegateInterception(Jsr299BindingsInterceptor.java:70) [wildfly-weld-8.2.0.Final.jar:8.2.0.Final]
	at org.jboss.as.weld.ejb.Jsr299BindingsInterceptor.doMethodInterception(Jsr299BindingsInterceptor.java:80) [wildfly-weld-8.2.0.Final.jar:8.2.0.Final]
	at org.jboss.as.weld.ejb.Jsr299BindingsInterceptor.processInvocation(Jsr299BindingsInterceptor.java:93) [wildfly-weld-8.2.0.Final.jar:8.2.0.Final]
	at org.jboss.as.ee.component.interceptors.UserInterceptorFactory$1.processInvocation(UserInterceptorFactory.java:63)



2. Is this a regression?
Comment 2 Tomer Saban 2015-09-24 09:28:10 EDT
Yes this is regression. It didn't happen before this version.
Comment 3 Yaniv Kaul 2015-09-24 10:20:44 EDT
(In reply to Tomer Saban from comment #2)
> Yes this is regression. It didn't happen before this version.

- Where's the regression keyword?
- Which version is that?
Comment 4 Tomer Saban 2015-09-24 11:03:23 EDT
I added the regression keyword.
Version is 4.0 as stated.
Comment 5 Tomer Saban 2015-09-24 11:14:54 EDT
Found on commit hash: 68c845eddce3a7bb6082431e725d44f5588c7d9c
Comment 6 Red Hat Bugzilla Rules Engine 2015-10-14 02:04:37 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 7 Red Hat Bugzilla Rules Engine 2015-10-19 06:50:29 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 Eli Mesika 2016-01-27 08:27:02 EST
Can not reproduce on master following scenario in bug description, please check scenario again on latest master and verify or provide additional details how to reproduce

Note You need to log in before you can comment on or make changes to this bug.