Bug 1266093 - [RFE] Deprecate ssl_verify_depth config and use openssl defaults.
[RFE] Deprecate ssl_verify_depth config and use openssl defaults.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 08:56 EDT by Adrian Likins
Modified: 2016-06-22 13:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-22 13:55:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Likins 2015-09-24 08:56:03 EDT
Description of problem:


We have a config option to set the X.509 server cert chain verify
depth to 3.

It was made configurable to address https://bugzilla.redhat.com/show_bug.cgi?id=649374
because it was explicitly set to '1' before that.

Why 3? (aside from 'thats what the current subscription.rhn.redhat.com cert needs to
get to redhat-uep.pem').

The openssl default seems to be 100 (https://www.openssl.org/docs/manmaster/ssl/SSL_CTX_set_verify.html)

My vote would be to let it fall to the openssl default by not explicitly setting it.
AFAICT, there is no utility to limiting the verify depth. 

Version-Release number of selected component (if applicable):
Pretty much all GA versions. But at least as new as: 
subscription-manager-1.16.2
python-rhsm-1.16.2




Additional info:
Comment 2 John Sefler 2015-09-25 13:17:03 EDT
deferring to rhel-7.3.0 due to schedule and severity

Note You need to log in before you can comment on or make changes to this bug.