Bug 1266155 - Master fails to start if networkConfig.serviceNetworkCIDR is unset
Master fails to start if networkConfig.serviceNetworkCIDR is unset
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Dodson
Meng Bo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 11:43 EDT by Scott Dodson
Modified: 2015-12-27 21:57 EST (History)
6 users (show)

See Also:
Fixed In Version: openshift-3.0.2.0-0.git.9.c4383ed.el7ose
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-01 13:14:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dodson 2015-09-24 11:43:31 EDT
Description of problem:
If a user is upgrading from 3.0.2 and hasn't followed the upgrade documentation and added a networkConfig.serviceNetworkCIDR to their master config the master will fail to start. We should be able to work around this by defaulting the value.

See https://github.com/openshift/origin/pull/4784

The error in the master logs is

SDN initialization failed: ClusterNetwork "default" is invalid: serviceNetwork: invalid value '', Details: invalid CIDR address:
Comment 1 Scott Dodson 2015-09-24 11:44:26 EDT
This is just backporting the upstream PR so assigning this to myself.
Comment 4 Anping Li 2015-09-25 05:14:59 EDT
I reproduced this issue on puddle 3.0/2015-09-16.2. After upgrade to 2015-09-24.1. the bug disappears.  so move bug to verified.

The reproduce steps is as the following:

1. Install prior version of openshift via ansible. For example: 3.0/2015-09-16.2.

2. systemctl stop openshift-master. and comment the line "serviceNetworkCIDR: 172.30.0.0/16" in master-config.yaml 
3. delete /var/lib/openshift/openshift.local.etcd/member

4. systemctl start openshift-master. I can hit the message as following. 

Sep 25 16:45:44 openshift-117.lab.eng.nay.redhat.com openshift-master[21539]: F0925 16:45:44.577209   21539 multitenant.go:36] SDN initialization failed: ClusterNetwork "default" is invalid: servic...DR address:
Sep 25 16:45:44 openshift-117.lab.eng.nay.redhat.com systemd[1]: openshift-master.service: main process exited, code=exited, status=255/n/a
Sep 25 16:45:44 openshift-117.lab.eng.nay.redhat.com systemd[1]: Unit openshift-master.service entered failed state.
Comment 6 errata-xmlrpc 2015-10-01 13:14:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1854

Note You need to log in before you can comment on or make changes to this bug.