This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1266228 - dnf is not updating full system
dnf is not updating full system
Status: CLOSED DUPLICATE of bug 1265336
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 16:12 EDT by RudraB
Modified: 2015-09-25 05:36 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 05:36:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RudraB 2015-09-24 16:12:14 EDT
Description of problem:
when using dnf update for full system, dnf is not working. I have to specify component. Like, if I specify package to  update, it shows:
$sudo dnf update gnome-shell
Last metadata expiration check performed 1:37:57 ago on Thu Sep 24 20:27:25 2015.
Dependencies resolved.
================================================================================
 Package           Arch         Version             Repository             Size
================================================================================
Upgrading:
 gnome-shell       x86_64       3.18.0-1.fc23       updates-testing       1.8 M
 mutter            x86_64       3.18.0-1.fc23       updates-testing       1.0 M

Transaction Summary
================================================================================
Upgrade  2 Packages

Total download size: 2.8 M
Is this ok [y/N]: 
Operation aborted.


But if I don't specify package, hope to update all packaged available, it doesn't do anything:

$sudo dnf update
Last metadata expiration check performed 1:38:03 ago on Thu Sep 24 20:27:25 2015.
Dependencies resolved.
Nothing to do.
Complete!


Version-Release number of selected component (if applicable):
dnf-1.1.2-2.fc23.noarch

How reproducible:
Always

Steps to Reproduce:
1. run dnf update 


Actual results:
not checking and updating 

Expected results:
It should check if any update is available, and update all packages available

Additional info:
Comment 1 Michael Mráka 2015-09-25 05:36:45 EDT

*** This bug has been marked as a duplicate of bug 1265336 ***

Note You need to log in before you can comment on or make changes to this bug.