Bug 1266232 - Dependency issue when installing Satellite 6.1.2 on RHEL 7.2
Dependency issue when installing Satellite 6.1.2 on RHEL 7.2
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.2
x86_64 Linux
unspecified Severity urgent (vote)
: 6.1.4
: --
Assigned To: Chris Peters
Tazim Kolhar
: Triaged
: 1277324 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 16:23 EDT by Og Maciel
Modified: 2017-02-23 14:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 15:33:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2015-09-24 16:23:57 EDT
Description of problem:

Installing Satellite 6.1.2 on a RHEL 7.2 x86_64 system fails with the following dependency error:

Error: Package: libdb-cxx-5.3.21-17.el7_0.1.x86_64 (rhel-7-server-satellite-6.1-rpms)
           Requires: libdb(x86-64) = 5.3.21-17.el7_0.1
           Installed: libdb-5.3.21-19.el7.x86_64 (@beaker-Server/7.2)
               libdb(x86-64) = 5.3.21-19.el7
           Available: libdb-5.3.21-17.el7.x86_64 (rhel-7-server-rpms)
               libdb(x86-64) = 5.3.21-17.el7
           Available: libdb-5.3.21-17.el7_0.1.x86_64 (rhel-7-server-rpms)
               libdb(x86-64) = 5.3.21-17.el7_0.1
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: libdb-cxx-5.3.21-17.el7_0.1.x86_64 (rhel-7-server-satellite-6.1-rpms)
           Requires: libdb(x86-64) = 5.3.21-17.el7_0.1
           Installed: libdb-5.3.21-19.el7.x86_64 (@beaker-Server/7.2)
               libdb(x86-64) = 5.3.21-19.el7
           Available: libdb-5.3.21-17.el7.x86_64 (rhel-7-server-rpms)
               libdb(x86-64) = 5.3.21-17.el7
           Available: libdb-5.3.21-17.el7_0.1.x86_64 (rhel-7-server-rpms)
               libdb(x86-64) = 5.3.21-17.el7_0.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):

* Satellite 6.1.2 on RHEL-7.2-20150924.n.0 Server

How reproducible:


Steps to Reproduce:
1. Enabled internal repo file pointing to RHEL-7.2-20150923.n.0 compose
2. Installed Satellite 6.1.2 enabling proper repositories
3.

Actual results:

Dependency error

Expected results:


Additional info:
Comment 4 Corey Welton 2015-11-11 09:55:35 EST
*** Bug 1277324 has been marked as a duplicate of this bug. ***
Comment 10 Tazim Kolhar 2015-11-16 11:31:39 EST
VERIFIED:
# rpm -qa | grep foreman
ruby193-rubygem-foreman_discovery-2.0.0.22-1.el7sat.noarch
foreman-debug-1.7.2.46-1.el7sat.noarch
foreman-libvirt-1.7.2.46-1.el7sat.noarch
hp-sl4540gen8-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
foreman-ovirt-1.7.2.46-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
foreman-1.7.2.46-1.el7sat.noarch
foreman-gce-1.7.2.46-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.3-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el7sat.noarch
foreman-postgresql-1.7.2.46-1.el7sat.noarch
foreman-compute-1.7.2.46-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.24-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
foreman-selinux-1.7.2.16-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
foreman-vmware-1.7.2.46-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
foreman-proxy-1.7.2.6-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
hp-sl4540gen8-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-sl4540gen8-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch

steps:
Enabled the internal repository for dependencies:
# cat internal_repo.repo 
[rhel72]
name=rhel72
baseurl=http://download.eng.rdu2.redhat.com/composes/nightly/RHEL-7.2-20151106.n.0/compose/Server/x86_64/os/
enabled=1
gpgcheck=0

# getenforce
Enforcing

Installation complete:
yum install -y katello

Complete!
Comment 11 Bryan Kearney 2015-11-19 15:33:00 EST
This fix was delivered in 6.1.4 on 19 November in https://access.redhat.com/errata/RHBA-2015:2474.

Note You need to log in before you can comment on or make changes to this bug.