Bug 1266234 - Receiving No srpm found error when using --no-build option
Receiving No srpm found error when using --no-build option
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 16:30 EDT by John Dulaney
Modified: 2016-04-29 14:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-29 14:36:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dulaney 2015-09-24 16:30:29 EDT
Description of problem:

When running fedora-review with the --no-build option, receive No srpm found error, even when the source rpm is, in fact present:

jdulaney@gefjon:~/rpmbuild$ ls
python-dulwich99-0.9.9-3.fc24.src.rpm  python-dulwich99.spec
jdulaney@gefjon:~/rpmbuild$ fedora-review --no-build -n python-dulwich99
INFO: Processing local files: python-dulwich99
INFO: Getting .spec and .srpm Urls from : Local files in /home/jdulaney/rpmbuild
INFO:   --> SRPM url: file:///home/jdulaney/rpmbuild/python-dulwich99-0.9.9-3.fc24.src.rpm
INFO:   --> Spec url: file:///home/jdulaney/rpmbuild/python-dulwich99.spec
INFO: Using review directory: /home/jdulaney/rpmbuild/review-python-dulwich99
WARNING: No cache found for /home/jdulaney/rpmbuild/review-python-dulwich99/upstream/dulwich-0.9.9.tar.gz, downloading anyway.
INFO: Downloading (Source0): https://pypi.python.org/packages/source/d/dulwich/dulwich-0.9.9.tar.gz
INFO: Running checks and generating report
WARNING: Package python-dulwich99-0.9.9-3.fc23 not built
WARNING: Package python-dulwich99-debuginfo-0.9.9-3.fc23 not built
ERROR: 'No srpm found for python-dulwich99' (logs in /home/jdulaney/.cache/fedora-review.log)
1 jdulaney@gefjon:~/rpmbuild$ 

This is also reproducible with -b <bug id> instead of passing local srpm and spec file.  This bug does not occur without the --no-build.


Version-Release number of selected component (if applicable):
fedora-review --version
fedora-review version 0.6.0 3c5c9d7 2015-05-20 21:46:22 +0200


Log contents:

/home/jdulaney/.cache/fedora-review.log

09-24 16:28 root         DEBUG    fedora-review 0.6.0 3c5c9d7 2015-05-20 21:46:22 +0200 started
09-24 16:28 root         DEBUG    Command  line: /usr/bin/fedora-review --no-build -n python-dulwich99
09-24 16:28 root         INFO     Processing local files: python-dulwich99
09-24 16:28 root         INFO     Getting .spec and .srpm Urls from : Local files in /home/jdulaney/rpmbuild
09-24 16:28 root         DEBUG    Active settings after processing options
09-24 16:28 root         DEBUG        resultdir: None
09-24 16:28 root         DEBUG        verbose: False
09-24 16:28 root         DEBUG        no_report: False
09-24 16:28 root         DEBUG        session_log: /home/jdulaney/.cache/fedora-review.log
09-24 16:28 root         DEBUG        list_flags: False
09-24 16:28 root         DEBUG        list_checks: False
09-24 16:28 root         DEBUG        single: None
09-24 16:28 root         DEBUG        rpm_spec: False
09-24 16:28 root         DEBUG        plugins: {}
09-24 16:28 root         DEBUG        exclude: None
09-24 16:28 root         DEBUG        configdir: None
09-24 16:28 root         DEBUG        log_level: 20
09-24 16:28 root         DEBUG        init_done: True
09-24 16:28 root         DEBUG        cache: True
09-24 16:28 root         DEBUG        mock_config: None
09-24 16:28 root         DEBUG        version: False
09-24 16:28 root         DEBUG        uniqueext: None
09-24 16:28 root         DEBUG        flags: []
09-24 16:28 root         DEBUG        bz_url: https://bugzilla.redhat.com
09-24 16:28 root         DEBUG        mock_options: --no-cleanup-after --no-clean
09-24 16:28 root         DEBUG        list_plugins: False
09-24 16:28 root         DEBUG        _log_config_done: True
09-24 16:28 root         DEBUG        other_bz: None
09-24 16:28 root         DEBUG        plugins_arg: None
09-24 16:28 root         DEBUG        repo: None
09-24 16:28 root         DEBUG        use_colors: True
09-24 16:28 root         DEBUG        bug: None
09-24 16:28 root         DEBUG        prebuilt: False
09-24 16:28 root         DEBUG        name: python-dulwich99
09-24 16:28 root         DEBUG        url: None
09-24 16:28 root         DEBUG        checksum: sha256
09-24 16:28 root         DEBUG        nobuild: True
09-24 16:28 root         DEBUG        _con_handler: <logging.StreamHandler object at 0x7fd2188c2410>
09-24 16:28 root         INFO       --> SRPM url: file:///home/jdulaney/rpmbuild/python-dulwich99-0.9.9-3.fc24.src.rpm
09-24 16:28 root         INFO       --> Spec url: file:///home/jdulaney/rpmbuild/python-dulwich99.spec
09-24 16:28 root         DEBUG    find_urls completed: 0.012
09-24 16:28 root         INFO     Clearing old review directory: /home/jdulaney/rpmbuild/review-python-dulwich99
09-24 16:28 root         INFO     Using review directory: /home/jdulaney/rpmbuild/review-python-dulwich99
09-24 16:28 root         DEBUG    Avoiding init of working mock root
09-24 16:28 root         DEBUG    Url download completed: 1.691
09-24 16:28 root         INFO     Using cached upstream: /home/jdulaney/rpmbuild/review-python-dulwich99/upstream/dulwich-0.9.9.tar.gz
09-24 16:28 root         INFO     Running checks and generating report
09-24 16:28 root         DEBUG    Running check: CheckResultdir
09-24 16:28 root         DEBUG        CheckResultdir completed: 0.000 seconds
09-24 16:28 root         DEBUG    Running check: CheckBuild
09-24 16:28 root         WARNING  Package python-dulwich99-0.9.9-3.fc23 not built
09-24 16:28 root         WARNING  Package python-dulwich99-debuginfo-0.9.9-3.fc23 not built
09-24 16:28 root         DEBUG        CheckBuild completed: 0.005 seconds
09-24 16:28 root         DEBUG    Running check: CheckRpmlint
09-24 16:28 root         DEBUG    ReviewError: 'No srpm found for python-dulwich99'
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 237, in run
    self._do_run(outfile)
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 226, in _do_run
    self._do_report(outfile)
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 99, in _do_report
    self._run_checks(self.bug.spec_file, self.bug.srpm_file, outfile)
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 118, in _run_checks
    writedown=not Settings.no_report)
  File "/usr/lib/python2.7/site-packages/FedoraReview/checks.py", line 378, in run_checks
    run_check(name)
  File "/usr/lib/python2.7/site-packages/FedoraReview/checks.py", line 352, in run_check
    check.run()
  File "/usr/lib/python2.7/site-packages/FedoraReview/plugins/generic_build.py", line 218, in run
    no_errors, retval = self.rpmlint_rpms()
  File "/usr/lib/python2.7/site-packages/FedoraReview/plugins/generic_build.py", line 98, in rpmlint_rpms
    rpms = Mock.get_package_rpm_paths(self.spec, with_srpm=True)
  File "/usr/lib/python2.7/site-packages/FedoraReview/mock.py", line 325, in get_package_rpm_paths
    result.append(get_package_srpm_path(spec))
  File "/usr/lib/python2.7/site-packages/FedoraReview/mock.py", line 314, in get_package_srpm_path
    raise ReviewError('No srpm found for ' + spec.name)
ReviewError: 'No srpm found for python-dulwich99'
09-24 16:28 root         ERROR    ERROR: 'No srpm found for python-dulwich99' (logs in /home/jdulaney/.cache/fedora-review.log)
09-24 16:28 root         DEBUG    Report completed:  3.730 seconds


Runing with -v gives same traceback.
Comment 1 Alec Leamas 2015-09-25 02:59:24 EDT
Looking at the logs we have:

WARNING  Package python-dulwich99-0.9.9-3.fc23 not built
WARNING Package python-dulwich99-debuginfo-0.9.9-3.fc23 not built

so the question is : Have you made a successful run before invoking fedora-review with the --no-build option?
Comment 2 Alec Leamas 2015-10-15 12:25:38 EDT
hm... I really need a reply to be able to handle this bug. Will close (no data) if no reply in some days.
Comment 3 John Dulaney 2015-10-15 15:12:51 EDT
Oh, sorry.  I didn't see an email.

So, if I do not invoke --no-build, then it works as expected, even on the same srpms.
Comment 4 Alec Leamas 2015-10-28 14:17:47 EDT
So, I still need a reply. Please answer question in comment #1
Comment 5 John Dulaney 2015-10-28 14:40:03 EDT
If I run it without --no-build, it works.
Comment 6 Alec Leamas 2015-10-28 14:43:31 EDT
That was not the question.  Could you please answer the question in comment #1 ?
Comment 7 John Dulaney 2015-10-28 14:56:15 EDT
so the question is : Have you made a successful run before invoking fedora-review with the --no-build option?

If I run it without --no-build, it works.
Comment 8 Alec Leamas 2015-10-28 15:05:41 EDT
Once again: The question is "Have you made a successful run before invoking fedora-review with the --no-build option?"

Now you have said three times that ir works for you without --no-build. Please don't repeat this info.

BTW: Have you read the manpage on the --no-build option?
Comment 9 Alec Leamas 2015-11-26 14:44:31 EST
Since you cannot provide an answer I'll close this bug, assuming that you are trying to use the --no-build option without a prior run without it (which obviously does not work)
Comment 10 John Dulaney 2015-11-26 16:43:52 EST
Have you, just out of curiosity, even attempted to reproduce this?

I answered your question, it does not matter what order I do things in, if I use the --no-build option *at all* then fedora-review blows up.
Comment 11 Alec Leamas 2015-11-26 17:04:24 EST
E. g., today I have been sitting a whole day fixing f-r bugs, more or less constantly using --no-build. This is my last comment in this bug.
Comment 12 John Dulaney 2015-12-06 14:27:38 EST
Have you tried running:

fedora-review --no-build -n <package-name>

as I originally reported?

Note You need to log in before you can comment on or make changes to this bug.