Bug 1266240 - vim-enhanced is missing libgpm.so.2 dependency
vim-enhanced is missing libgpm.so.2 dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
23
aarch64 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 16:53 EDT by Jeff Bastian
Modified: 2015-09-25 09:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 09:18:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2015-09-24 16:53:18 EDT
Description of problem:
I cannot install vim-enhanced due to a missing dependency on libgpm.so.2()(64bit).

[root@bumblebee ~]# uname -r
4.2.0-300.fc23.aarch64

[root@bumblebee ~]# dnf repolist
Last metadata expiration check performed 0:10:38 ago on Thu Sep 24 15:38:32 2015.
repo id                     repo name                                     status
f23                         f23                                           2,224
*updates                    Fedora 23 - aarch64 - Updates                     0
*updates-testing            Fedora 23 - aarch64 - Test Updates            6,423

[root@bumblebee ~]# dnf install vim-enhanced
Last metadata expiration check performed 0:09:29 ago on Thu Sep 24 15:38:32 2015.
Error: nothing provides libgpm.so.2()(64bit) needed by vim-enhanced-2:7.4.827-1.fc23.aarch64
(try to add '--allowerasing' to command line to replace conflicting packages)

Version-Release number of selected component (if applicable):
vim-enhanced-7.4.827-1.fc23.aarch64

How reproducible:
always

Steps to Reproduce:
1. install Fedora 23 Beta
2. dnf install vim-enhanced

Actual results:
cannot install vim-enhanced due to missing libgpm.so.2()(64bit)

Expected results:
install vim-enhanced

Additional info:
Comment 1 Jeff Bastian 2015-09-24 16:56:25 EDT
I found a gpm package in koji:
http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=296762

I installed that rpm manually and then I could install vim-enhanced.

[root@bumblebee ~]# wget http://arm.koji.fedoraproject.org//packages/gpm/1.20.7/7.fc23/aarch64/gpm-libs-1.20.7-7.fc23.aarch64.rpm
...
[root@bumblebee ~]# dnf install gpm-libs-1.20.7-7.fc23.aarch64.rpm 
...
[root@bumblebee ~]# dnf install vim-enhanced
...
Installed:
  vim-common.aarch64 2:7.4.827-1.fc23     vim-enhanced.aarch64 2:7.4.827-1.fc23
  vim-filesystem.aarch64 2:7.4.827-1.fc23

Complete!
Comment 2 Karsten Hopp 2015-09-25 09:18:15 EDT
gpm-1.20.7-7.fc23 got moved to f23-beta yesterday. This should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.