Bug 1266256 - Fedora 22 Live image cannot boot with Intel Skylake i7-6500U CPU
Fedora 22 Live image cannot boot with Intel Skylake i7-6500U CPU
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 17:49 EDT by Phu
Modified: 2016-07-19 15:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 15:57:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phu 2015-09-24 17:49:35 EDT
Description of problem:
Blank screen when booting Fedora 22 images on a Gigabyte motherboard with latest Intel's Skylake i7-6500U CPU @2.5 GHz


Version-Release number of selected component (if applicable):
Fedora-Live-Workstation-x86_64-22.iso
Fedora-Workstation-netinst-x86_64-22.iso


How reproducible:
100%

Steps to Reproduce:
1.Load above ISO images to a USB stick and boot with above hardware
2.
3.

Actual results:
Blank screen after boot image is selected

Expected results:
Full windows with Try out or installation to hard disk options.

Additional info:
Motherboard Manufacturer: GIGABYTE
Product name: MKLP7A1-B9
Processor info
Socket Designator: U3E1
Family: Core i7
Version: Intel(R) Core(TM) i7-6500U CPU @ 2.5GHz
Comment 1 Joshua Rosen 2015-10-10 09:53:13 EDT
I have a similar system, i6700K on a Gigabyte GA-Z170XP-SLI. I suggest that you try F23 Beta. The F22 installer uses a 4.0 kernel which doesn't support the NIC on the board. F23 uses a 4.2.x kernel which has much better support for Skylake. I also suggest that you update your BIOS, that was the first thing I did before doing any installs. I was able to install F22 and Scientific Linux 7.1 but both suffered from the unsupported Ethenet NIC, F23 is the best choice for Skylake systems.
Comment 2 Phu 2015-10-12 15:46:44 EDT
I just tried booting with a couple of F23 images, Fedora-Live-Workstation-x86_64-23_Beta-1.iso and Fedora-Server-netinst-x86_64-23_Beta.iso with no better result.
Comment 3 Phu 2015-10-12 15:54:41 EDT
I suspect the problem is with the Graphics driver rather than the ethernet driver as the Skylake i7-6500U is for mobile.
Comment 4 Joshua Rosen 2015-10-12 16:00:48 EDT
Have you updated your BIOS to the latest rev? The BIOS on my motherboard was F2 which was the first release, I updated mine to F5A, which was released Sept 15, before I did any installs. If the BIOS update doesn't fix it I suggest you play around with graphics settings in the BIOS.

One more question, what sized monitor are you using? I did my install using an old 1280x1024 monitor.
Comment 5 Phu 2015-10-14 15:48:27 EDT
I modified grub to use this option to no avail.

GRUB_CMDLINE_LINUX=" rhgb quiet i915.preliminary_hw_support=1"

Connecting to an older monitor did not help either. My BIOS date is 9/11/15.
I am also working with Gigabyte in the background
I hope that Fedora folks can spare sometime to provide some insight into this problem between Fedora and Skylake i7-6500U.
Comment 6 Joshua Rosen 2015-10-14 17:50:49 EDT
Have you tried any other distros? I'd try Ubuntu 15.10 (which is also a beta) just to see if it's a Fedora issue or a Linux issue with the 6500U. If all else fails do you have an old Nvidia card to use during the install, once installed I'd then do the updates and then see if it boots without the Nvidia card.
Comment 7 Phu 2015-11-11 13:32:53 EST
This is a newer motherboard with the Skylake 6500U CPU so older graphics card cannot connect to it at all. In any case, I turned off the quiet mode  in the boot line and here are the last couple lines before the system hangs:

rtc-cmos 00:03: RTC can wake from S4
rtc-cmos 00:03: rtc core: registered rtc_cmos s rtc0
rtc-cmos 00:03: alarms up to one month, y3k, 242 bytes nvram, hpe irqs
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.30.0-ioctl (2014-12-22) initialised: dm-devel@redhat.com
Intel P-state driver initializing
inter_pstate HWP enabled
Comment 8 Max 2015-12-27 19:34:50 EST
(In reply to Phu from comment #0)
> Description of problem:
> Blank screen when booting Fedora 22 images on a Gigabyte motherboard with
> latest Intel's Skylake i7-6500U CPU @2.5 GHz
I get same on Fedora 23 with i5 Ivy Bridge.
Comment 9 Fedora End Of Life 2016-07-19 15:57:14 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.