This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 126639 - GtkIconFactory incorrectly uses g_free on a GdkPixbuf
GtkIconFactory incorrectly uses g_free on a GdkPixbuf
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
http://bugzilla.gnome.org/show_bug.cg...
:
Depends On: 125739
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-23 23:02 EDT by Bojan Smojver
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-10 01:42:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2004-06-23 23:02:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.15

Description of problem:
In gtkiconfactory.c, icon_source_clear performs a g_free on a
GdkPixbuf object. This is wrong, as its an object, it should just be
performing an g_object_unref on it. I'll attach the obvious patch
(which isn't tested).

See GNOME bug: 141961

http://bugzilla.gnome.org/show_bug.cgi?id=141961

This bug normally crashes Galeon 1.3.15 when a download is cancelled.

Version-Release number of selected component (if applicable):
gtk2-2.4.0-1

How reproducible:
Always

Steps to Reproduce:
1. Run Galeon 1.3.15, click to download a file.
2. Cancel download.
3. Repeat until Galeon crashes.

IMPORTANT: THIS IS NOT A BUG IN GALEON!
    

Actual Results:  Galeon crashes due to a bug in gtk+ 2.4.0.

Expected Results:  There should be no crash.

Additional info:

This is fixed in gtk+-2.4.3, so this RPM just need a bit of a rebuild.

Note You need to log in before you can comment on or make changes to this bug.