Bug 1266397 - After running openshift with a period of time get event is empty
After running openshift with a period of time get event is empty
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 04:03 EDT by DeShuai Ma
Modified: 2016-05-12 13:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:14:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DeShuai Ma 2015-09-25 04:03:01 EDT
Description of problem:
After running openshift with a period of time get event is empty

Version-Release number of selected component (if applicable):
openshift v1.0.6-155-gf162bfb
kubernetes v1.1.0-alpha.0-1605-g44c91b1

How reproducible:
Always

Steps to Reproduce:
1.Start openshift all-in-one

2.Get event
[fedora@ip-172-18-12-107 sample-app]$ oc get event
FIRSTSEEN   LASTSEEN   COUNT     NAME                       KIND                    SUBOBJECT                           REASON                                               SOURCE                       MESSAGE
2m          2m         1         ip-172-18-12-107           Node                                                        NodeReady                                            {kubelet ip-172-18-12-107}   Node ip-172-18-12-107 status is now: NodeReady
2m          2m         1         ip-172-18-12-107           Node                                                        starting                                             {kubelet ip-172-18-12-107}   Starting kubelet.
2m          2m         1         ip-172-18-12-107           Node                                                        Registered Node ip-172-18-12-107 in NodeController   {controllermanager }         Node ip-172-18-12-107 event: Registered Node ip-172-18-12-107 in NodeController

3.Wait a period of time and get event
[fedora@ip-172-18-12-107 sample-app]$ oc get event
FIRSTSEEN   LASTSEEN   COUNT     NAME      KIND      SUBOBJECT   REASON    SOURCE    MESSAGE

Actual results:
3.Get event is empty

Expected results:
3.Should get some event

Additional info:
Comment 1 Fabiano Franz 2015-09-28 11:01:17 EDT
I was not able to reproduce it, could you add more information like how much time is needed until you start getting an empty result?
Comment 2 Fabiano Franz 2015-09-28 11:03:28 EDT
Adding pmorie, could this be related to event caching?
Comment 3 DeShuai Ma 2015-10-07 22:34:38 EDT
There is no fixed time interval. you can reproduce it by more than some hours.
Comment 4 DeShuai Ma 2015-10-22 03:13:28 EDT
Test on ose env. same issue. this bug need to fix.
rpm version:
atomic-openshift-3.0.2.902-0.git.0.721dd17.el7aos.x86_64
[root@openshift-140 ~]# openshift version
openshift v3.0.2.902
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2
[root@openshift-140 ~]# oc whoami
system:admin
[root@openshift-140 ~]# oc get event -n default
[root@openshift-140 ~]#
Comment 5 Fabiano Franz 2016-01-08 12:46:55 EST
Unable to reproduce, putting ON_QA to check if it still can be reproduced. If so, please try to determine around how many hours it take until the issue is seen.
Comment 6 DeShuai Ma 2016-01-10 21:50:59 EST
In the latest version of openshift can't reproduce this bug. when this reproduce will reopen this bug.

verify on env:
[fedora@ip-172-18-5-254 sample-app]$ openshift version
openshift v1.1-428-ged29520
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

Note You need to log in before you can comment on or make changes to this bug.