Bug 1266423 - [abrt] hplip: status.py:33:<module>:ImportError: No module named cupsext
[abrt] hplip: status.py:33:<module>:ImportError: No module named cupsext
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:b4e2b1363321127ce43588ad475...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 04:54 EDT by Abhay Kadam
Modified: 2015-10-01 12:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: hplip-3.15.9-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-01 12:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.49 KB, text/plain)
2015-09-25 04:54 EDT, Abhay Kadam
no flags Details
File: environ (72 bytes, text/plain)
2015-09-25 04:54 EDT, Abhay Kadam
no flags Details

  None (edit)
Description Abhay Kadam 2015-09-25 04:54:39 EDT
Version-Release number of selected component:
hplip-3.15.9-1.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python /usr/bin/hp-config_usb_printer 001:002
executable:     /usr/bin/hp-config_usb_printer
kernel:         4.2.0-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
#1 <module> in /usr/share/hplip/base/status.py:33
#2 <module> in /usr/share/hplip/base/device.py:42
#3 <module> in /usr/bin/hp-config_usb_printer:34
Comment 1 Abhay Kadam 2015-09-25 04:54:47 EDT
Created attachment 1076956 [details]
File: backtrace
Comment 2 Abhay Kadam 2015-09-25 04:54:49 EDT
Created attachment 1076957 [details]
File: environ
Comment 3 Jiri Popelka 2015-09-25 08:20:18 EDT
Thank you for the report.

hplip-printer@.service contains
ExecStart=/usr/bin/python /usr/bin/hp-config_usb_printer "%i"
which runs hp-config_usb_printer with Python 2, while hp-config_usb_printer itself contains #!/usr/bin/python3 shebang.

We haven't been shipping the necessary python2 libraries since 3.15.7-5, which causes the error you see.

Problem should be fixed in hplip-3.15.9-2.fc23 where the ExecStart in hplip-printer@.service looks like:
ExecStart=/usr/bin/hp-config_usb_printer "%i"
Comment 4 Fedora Update System 2015-09-25 09:07:51 EDT
hplip-3.15.9-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-cd4b81fa34
Comment 5 Fedora Update System 2015-09-26 20:55:12 EDT
hplip-3.15.9-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update hplip'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cd4b81fa34
Comment 6 Fedora Update System 2015-10-01 12:01:26 EDT
hplip-3.15.9-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.