Bug 1266449 - [origin_userinterface_521]Didn't autofocus name field on create from image page
[origin_userinterface_521]Didn't autofocus name field on create from image page
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 06:32 EDT by yapei
Modified: 2016-12-02 12:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-02 12:29:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wss-warning (190.37 KB, image/png)
2015-09-28 00:14 EDT, Yanping Zhang
no flags Details
xhr-time (167.13 KB, image/png)
2015-09-28 00:15 EDT, Yanping Zhang
no flags Details

  None (edit)
Description yapei 2015-09-25 06:32:39 EDT
Description of problem:
Create application from image, after select builder image, it should automatically goes to create page and autofocus on name field, but on fork_ami, it didn't autofocus 

Version-Release number of selected component (if applicable):
fork_ami_openshift3_userinterface_public_521_89
Firefox 40.0.3
Chrome 44
IE 11

How reproducible:
Always

Steps to Reproduce:
1.Create some image streams 
2.Click on one image, it will goes to create page

Actual results:
it didn't autofocus on name field

Expected results:
Should autofocus on name field on create image page


Additional info:
Comment 1 Samuel Padgett 2015-09-25 11:45:00 EDT
Can you check if there are any errors in your JavaScript console?

In Chrome,

View -> Developer -> JavaScript Console

Can you also open developer tools before clicking the builder tile and check how long the page takes to load?

View -> Developer -> Developer Tools

Switch to the Network tab and then click XHR and take a screenshot.

I suspect it takes more than 300ms, which will interfere with the autofocus.
Comment 2 Yanping Zhang 2015-09-28 00:13:44 EDT
Tested on devenv-fedora_2411
$ openshift version
openshift v1.0.6-188-g347cf33
kubernetes v1.1.0-alpha.0-1605-g44c91b1
Still cann't autofocus on "Name".

Access on firefox 40 and chrome 47, there is wss warning info on image/template list page.
The time in XHR is about 400ms~500ms.
You can refer to the attachment.
Comment 3 Yanping Zhang 2015-09-28 00:14 EDT
Created attachment 1077845 [details]
wss-warning
Comment 4 Yanping Zhang 2015-09-28 00:15 EDT
Created attachment 1077846 [details]
xhr-time
Comment 5 Samuel Padgett 2015-09-28 07:35:10 EDT
Perfect, thanks. I think the problem is that the page takes a couple seconds to load fully for you. When content on the page is changes as requests complete, the name field loses focus. I'll have to think about a solution. I'm hesitant to force focus after so long because it's possible the user has interacted with the form already.
Comment 6 Samuel Padgett 2016-12-02 12:29:27 EST
Closing as WONTFIX. See comment 5.

This only happens when the page takes more than a few seconds to load, and it could be annoying to change focus back to name if the user has tabbed out or changed something else in that time.

Note You need to log in before you can comment on or make changes to this bug.