Bug 1266537 - [Doc] Provide more details about DNS requirements
[Doc] Provide more details about DNS requirements
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Timothy
Johnny Liu
Vikram Goyal
:
: 1271400 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 10:28 EDT by Ricardo Martinelli de Oliveira
Modified: 2016-11-08 01:29 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 20:24:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricardo Martinelli de Oliveira 2015-09-25 10:28:25 EDT
Document URL: 
https://docs.openshift.com/enterprise/3.0/install_config/install/prerequisites.html#environment-requirements

Section Number and Name: 
Prerequites > Environment

Describe the issue: 
Provide more details and clarify about DNS requirements. The document still lack of information about it

Suggestions for improvement: 
All information needed (or at least most of it) is described in https://access.redhat.com/solutions/1520803

Additional information:
Comment 2 Vikram Goyal 2015-10-14 21:03:39 EDT
*** Bug 1271400 has been marked as a duplicate of this bug. ***
Comment 4 Ryan Howe 2016-05-13 17:32:41 EDT
We should outline that DNS is needed for OpenShift to work fully. 

https://docs.openshift.com/enterprise/latest/install_config/install/prerequisites.html#prereq-dns


The masterURL needs to be resolvable to the LB or Master so that a pod can resolve the masterURL.
Comment 5 Timothy 2016-05-19 00:54:28 EDT
work-in-progress docs: https://github.com/openshift/openshift-docs/pull/2101
Comment 8 Timothy 2016-05-25 21:28:43 EDT
https://github.com/openshift/openshift-docs/pull/2101

made updates, just asking SME questions in BZ:

@rimolive : I understand what you're saying, that blog is for an all-in-one so it has no bearing on enterprise docs. I'm just wondering if there's enough information here for our users to be able to properly configure DNS for a typical cluster (multiple masters and nodes). Am I missing anything in there?
Comment 9 Timothy 2016-06-07 00:56:14 EDT
https://github.com/openshift/openshift-docs/pull/2101

made more updates, asking Ryan Howe for a final tech review, since I incorporated his notes.
Comment 10 Timothy 2016-06-15 01:02:12 EDT
Updated again, back to Ryan Howe on something I'm unclear about.
Comment 11 Timothy 2016-06-23 00:34:08 EDT
https://github.com/openshift/openshift-docs/pull/2101

More updates made based on more tech review

Rendered doc for easy reading: http://file.bne.redhat.com/~tpoitras/2016/BZ1266537/openshift-enterprise/dnsreqs-BZ1266537/install_config/install/prerequisites.html#prereq-dns

updated PR based on Tech Review, moving to QA.
Comment 12 Ryan Howe 2016-06-28 08:03:23 EDT
See PR comments 

https://github.com/openshift/openshift-docs/pull/2101
Comment 14 Timothy 2016-06-29 22:51:29 EDT
Moving along to QE for verification that everything here works.

Attn: Ma Xiaoqiang

in the GitHub PR mentioned above, I have made many updates to the following section regarding DNS configuration:

http://file.bne.redhat.com/%7Etpoitras/2016/BZ1266537/openshift-enterprise/dnsreqs-BZ1266537/install_config/install/prerequisites.html#prereq-dns

Please QE test this section for technical accuracy.

Thank you,

Timothy
Comment 15 Johnny Liu 2016-06-29 23:45:13 EDT
Go through the whole DNS section, I did not find any info about how to add master/node DNS record, also not mentioned which kind of DNS server is suggested to use? dnsmsaq installed on node? customized internal bind dns server installed by user? or some office DNS server in user's environment. Most are telling user how to check and validate its DNS configuration. Maybe some user will get confused about why "dig ose3-node1.example.com  @172.16.25.41" would result a IP address.

Except the above issue, other part seem good to me.
Comment 16 Timothy 2016-07-03 00:43:29 EDT
@Johnny Liu:

I'm not sure I understand. I have re-organized the content to make it flow a bit better, but I'm not sure about the things you're mentioning above. 

You said: "I did not find any info about how to add master/node DNS record"

Most of this is automated now. "As of OpenShift Enterprise 3.2, dnsmasq is automatically configured on all nodes."

So there's just a couple things to check:

The "Configuring a DNS Environment" shows the process involved: ensure DNS server resolve to all masters & nodes, and if DHCP is enabled, a script takes care of configuration (but you can optionally configure dnsIP in the node-config). If DHCP is disabled, then configure your network interface to be static, and add DNS nameservers to NetworkManager.

------------------------

You said: "also not mentioned which kind of DNS server is suggested to use? dnsmsaq installed on node? customized internal bind dns server installed by user? or some office DNS server in user's environment."

From the docs: "As of OpenShift Enterprise 3.2, dnsmasq is automatically configured on all nodes."

I'm not sure about the types of DNS servers... do we have data on this anywhere?

------------------------

You said: "Most are telling user how to check and validate its DNS configuration. Maybe some user will get confused about why "dig ose3-node1.example.com  @172.16.25.41" would result a IP address.""


I've hopefully clarified this a bit better.

Please re-check this link for updated docs:

http://file.bne.redhat.com/%7Etpoitras/2016/BZ1266537/openshift-enterprise/dnsreqs-BZ1266537/install_config/install/prerequisites.html#prereq-dns
Comment 17 Johnny Liu 2016-07-04 04:03:13 EDT
Looks like good to me.
Comment 18 Timothy 2016-07-04 20:51:58 EDT
Thanks, Johnny! Moving PR to peer review and moving this BZ to release-pending
Comment 19 Timothy 2016-07-05 00:08:43 EDT
PR has merged: https://github.com/openshift/openshift-docs/pull/2101

Once published, will close this BZ.

Note You need to log in before you can comment on or make changes to this bug.