Bug 126658 - via_rhine works with SMP kernel but not UP
Summary: via_rhine works with SMP kernel but not UP
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-24 13:32 UTC by Chris Adams
Modified: 2015-01-04 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 05:35:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Adams 2004-06-24 13:32:38 UTC
I changed out the motherboard in my system to an EPoX 8KRAI, which is
an VIA KT600 chipset board with a VIA VT6102 ethernet chip.  The old
mboard was dual processor, so I had the SMP kernel booting by default,
and everything worked on the new mboard that way.  When I switched to
the UP kernel, I got:

NETDEV WATCHDOG: eth0: transmit timed out
eth0: Transmit timed out, status 0003, PHY status 786d, resetting... 
eth0: Reset not complete yet. Trying harder.
irq 10: nobody cared! (screaming interrupt?)
 [<021070de>] __report_bad_irq+0x2b/0x67
 [<02107176>] note_interrupt+0x43/0x66
 [<0210733c>] do_IRQ+0x109/0x169
 [<0210722f>] enable_irq+0x60/0x64
 [<228cef9e>] rhine_tx_timeout+0x94/0xd9 [via_rhine]
 [<0224248e>] dev_watchdog+0x51/0x7c
 [<0224243d>] dev_watchdog+0x0/0x7c
 [<0211dcab>] run_timer_softirq+0x10b/0x12a 
 [<0211ae01>] __do_softirq+0x35/0x73
 [<0210790a>] do_softirq+0x46/0x4d
 =======================
 [<02107390>] do_IRQ+0x15d/0x169
 [<021b38a1>] acpi_processor_idle+0xd3/0x1c5
 [<0210408c>] cpu_idle+0x1f/0x34
 [<0231c51b>] start_kernel+0x178/0x17a

handlers:
[<022169f4>] (usb_hcd_irq+0x0/0x4b)
[<022169f4>] (usb_hcd_irq+0x0/0x4b)
[<228cf1a7>] (rhine_interrupt+0x0/0x144 [via_rhine])
Disabling IRQ #10

during boot, and then the network didn't work.  Reboot into SMP and it
works (so that's what I'm running now).  Suggestions?

Comment 1 Chris Adams 2004-06-29 19:50:13 UTC
Even with the SMP kernel, I get a lot of timeouts:

NETDEV WATCHDOG: eth0: transmit timed out
eth0: Transmit timed out, status 0000, PHY status 786d, resetting...

Comment 2 Chris Adams 2004-08-30 19:40:30 UTC
The problem isn't just the network; it appears to be ACPI related.

Everything that gets assigned to IRQ 10 with ACPI enabled doesn't
work; network times out, sound loops, etc.  If I boot with "acpi=off"
it is all assigned to IRQ 5 instead, and seems to work.  The network
still times out sometimes though, so I would suspect there's still a
problem.

Comment 3 Dave Jones 2005-01-14 05:21:22 UTC
is this any better with the 2.6.10 updates ?


Comment 4 Chris Adams 2005-01-26 22:57:56 UTC
Not in some quick testing.  I have updated to FC3 (clean install to
another drive actually), so I'll check a little more when I get a
chance, but last I tried, the system hangs (or takes a long time)
during boot (when it hits the USB init) if I don't put "acpi=off". 
The built in sound and network are flakey even with "acpi=off", so
I've put in a NIC and sound card (that's why it'll take some work for
testing).

If there more things to try or debugging info to gather, let me know.

Comment 5 Dave Jones 2005-04-16 05:35:34 UTC
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.



Note You need to log in before you can comment on or make changes to this bug.