Bug 1266644 - rhscl-rh-java-common install problem
rhscl-rh-java-common install problem
Status: CLOSED CURRENTRELEASE
Product: softwarecollections.org
Classification: Community
Component: rh-java-common (Show other bugs)
1.0
x86_64 Other
unspecified Severity urgent
: ---
: ---
Assigned To: Mikolaj Izdebski
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 20:44 EDT by skippyvondrake
Modified: 2015-09-29 03:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-29 03:06:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description skippyvondrake 2015-09-25 20:44:37 EDT
Description of problem:
Followed instructions at 
   https://www.softwarecollections.org/en/scls/rhscl/rh-java-common/
But install process fails on Step#4 in those instructions.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. yum install scl-utils 
2. yum install rhscl-rh-java-common-*.noarch.rpm
3. yum install rh-java-common

Actual results:
 No package 'rh-java-common' available

Expected results:
 A message saying component was successfully installed.

Additional info:
 Using  CentOS release 6.6 (Final)
Comment 1 skippyvondrake 2015-09-26 09:54:48 EDT
Today I installed Maven30-rhel-6 using these instructions:
 https://www.softwarecollections.org/en/scls/mizdebsk/maven30-rhel-6/

That package installed successfully. I did this in case it was a requirement for the "rh-java-common" package.

Then I re-attempted to install the "rh-java-common" package described in the ticket but still resulted in the same problem.
I also attempted the re-install after enabling maven:
  sudo scl enable maven30 bash
But still no difference in the outcome originally described.
Comment 2 skippyvondrake 2015-09-26 12:09:56 EDT
Note I used 'sudo' for the above commands but then tried the same with 'su' and saw no change.
Comment 3 Mikolaj Izdebski 2015-09-28 03:07:06 EDT
Confirmed - it is reproducible for me as well.
Comment 4 Mikolaj Izdebski 2015-09-28 03:38:32 EDT
The reason is simple - there is no rh-java-common package because this collection is not supposed to be installed directly. Installation instructions are incorrect.

Copr team: Can we remove steps 4 and 5 from installation instructions at https://www.softwarecollections.org/en/scls/rhscl/rh-java-common/ and add a note like: "This collection provides common components used by other collections and is not supposed to be installed directly by users."
Comment 5 Miroslav Suchý 2015-09-28 05:13:37 EDT
I can alter the change, but I would rather add there documentation how other collections should use it as well.

So how other collections should use it?
Comment 6 Mikolaj Izdebski 2015-09-28 09:31:20 EDT
I'm not sure I understand the question. Can you be more specific?

rh-java-common is just a set of various shared libraries and tools used by other collections. It was created to avoid package duplication between different SCLs - collections like maven30 or thermostat1 depend on packages from rh-java-common. Users shouldn't need to directly install any packages from rh-java-common (with exception of YUM repo definition package, which is not strictly part of rh-java-common, but it is provided in the same repo).
Comment 7 Miroslav Suchý 2015-09-29 02:34:27 EDT
Text at https://www.softwarecollections.org/en/scls/rhscl/rh-java-common/ has been altered.
Comment 8 Mikolaj Izdebski 2015-09-29 03:06:10 EDT
Thank you, I'm closing this as resolved.

Note You need to log in before you can comment on or make changes to this bug.